BYOND Version:510.1329
Operating System:Windows 10 Home 64-bit
Web Browser:Chrome 48.0.2564.116
Applies to:Dream Maker
Status: Open

Issue hasn't been assigned a status value.
Descriptive Problem Summary: When opening Dream Maker, if the map file is loaded up first (as the last file open in the previous session), if you attempt to ctrl+k to compile as the object tree begins to generate you will crash Dream Maker and either wipe the map file out completely, or wipe the map file out and be left with an unopenable partially complete map.

Numbered Steps to Reproduce Problem:

1. Open Dream Maker, compile everything up, load a dmm file.
2. Close Dream Maker.
3. Open Dream Maker so that the dmm file is loaded as the program opens.
4. Hit ctrl+k as soon as the program opens.
5. Crash.
6. Reopen Dream Maker to find your hard work completely gone with no backup.
7. Remap all that stuff.

Code Snippet (if applicable) to Reproduce Problem:

Expected Results:

Probably shouldn't crash and wipe your map file in the process?

Actual Results:

Goodbye map work.

Does the problem occur:
Every time? Or how often? I can reproduce it consistently back into early 509 releases, haven't had a chance to test further back. I assume it's as old as the release that added code to generate the object tree on loading a map file even without compiling.
In other games? Every project I've tried.
In other user accounts? Yep.
On other computers? Yep.

When does the problem NOT occur?

When you wait for the object tree to generate and the map to load before hitting ctrl+k.

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.) Seems to go back a ways.

Other stuffs

I can only assume it's crashing because you try to compile while the object tree is loading, which makes the object tree process begin twice and smash into itself, at the same time the compiler is working on compiling the map during the crash leading to the corrupt data (in my case a 10x10 empty map that had to be fixed in notepad to load)

(Sorry about the lack of real depth, took me forever to type this on my phone)
this has happened to me so many times but i never bothered looking to see what caused it
this is one of the many reasons it should autosave maps to a temp file.