Regressia

by IainPeregrine
Regressia
Relive the glory days of gaming with a new single-player RPG. Regressia is a BYOND game like no other. It is 100% complete and uses all original Graphics, Music, and Programming. This is the real experience.
ID:2158596
 
BYOND Version:510
Operating System:Windows 10 Home
Web Browser:Chrome 53.0.2785.143
Applies to:BYOND Pager
Status: Open

Issue hasn't been assigned a status value.
Descriptive Problem Summary:
When I attempt to install or play "Regressia"using the BYOND Pager or the website, the game appears to have finished installation, but never opens, and the "Install" option remains.

Numbered Steps to Reproduce Problem:
1. Go to pager's "Regressia" game and click "Install" or "Play." Or, go to website "Regressia" page and click "Download."

Code Snippet (if applicable) to Reproduce Problem:


Expected Results:
Launch game.

Actual Results:
No game launch, and "Install" option remains.

Does the problem occur:
Every time? Or how often? Every time.
In other games? This is the only game I've noticed, so far.
In other user accounts? I've only tried my account.
On other computers? I've only tried my Windows 10 laptop.

When does the problem NOT occur?
Non-applicable. The problem occurs each time.

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit http://www.byond.com/download/build to download old versions for testing.)
I'll post here again if I am able to find a previous version that works. Trying a previous version is a great idea.

Workarounds:
Finding a previous version may work. I will post here if I find a version that works.
I found an old zip file that kinda works. Looks like an update to the BYOND software, probably the skin system or something to do with screen objects, has rendered the game almost unplayable. Could probably be fixed by finding that section of the code and fixing it. I probably have the code around somewhere, but no time to work on it. Would be willing to give someone trustworthy the ability to access the code and fix it, though.
Hey, Iain! I'm kinda like you in that I'm pretty busy, so though I'd be interested in trying to update it so it runs in BYOND 5.0, I'm also unable to put in the time, for now.

Once I finish my degree, I'd like to figure out what version of BYOND it currently works with, and do a Let's Play and installation video showing people how to get it to work. That would be nice because people could still know how to play, and you wouldn't have to give your code to anyone, and it would also get the game out there for any of my subs who might be interested (although I admittedly only have a few subs on my Tyruswoo Gaming channel right now, but perhaps there will be more in the future).

Thanks for the response!
Turns out it was easy enough to fix - assuming this fix works for everyone and not just on my computer.

All I needed to do was add 'view = "17x15";' in client/New() and it got it working. Enjoy!
I just tested out the title screen and watched the first couple sentences of the cutscene, and it is working!

I quit before I got any further in, because I want to save my reactions for when I record for my channel! I'll tell everyone to go check it out for themselves and suggest that if they enjoy the content they should consider subscribing to your games! I'm excited that it is working again, because even that first little part seemed pretty polished in music and art! Looking forward to playing it!
Before you do ANYTHING else in Eastarbor, SAVE at the Inn. I don't know why I made tickets so expensive.