Descriptive Problem Summary: I've bought a new windows 10 laptop and when I play ss13 the 'options' in the top right are very small as well as all the gui's. I also recieve some majour graphical errors in the game

Numbered Steps to Reproduce Problem: Windows 10> Open byond> search for tgstation on the internet> click on sybil> game loads> words and gui's are small> press play game> graphical errors.

Code Snippet (if applicable) to Reproduce Problem:

Expected Results: The text boxes and gui's to be bigger and for the black box graphical error not to be there.

Actual Results: small gui's and textboxes/text and black boxes around objects/certain things not displaying properly

Does the problem occur:
Every time? Or how often? Every time
In other games? Yes
In other user accounts? Yes
On other computers? No

When does the problem NOT occur? Never

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.) I only just got my laptop yesterday.

Workarounds: (not sure what this means)

The GUI text size is something you'll have to take up with the SS13 developers. BYOND currently does not auto-adjust the size of UI elements to match Windows' built-in text scaling feature for high-res displays. (This is on the list to look at for 512.) If the game lets you edit the skin, then I would suggest making some alterations to the skin yourself to make the font size bigger. If not, ask the developers to provide an option for this.

As for the graphics issue, that'd be a separate problem and is likely related to your graphics card. There are some support threads already in BYOND Help regarding SS13 graphical issues, and one of the things you can try is reinstalling DirectX fully to see if that fixes anything.

But before that, I would suggest trying the newer beta builds for 511 rather than sticking with 510. The graphics handling is a bit different in newer builds and it may end up completely fixing the graphical problem.
I reinstalled directx and it fixed the graphical bug, except space is white now. Also, you think if I changed my OS to windows 7 it would fix these issues?
HEY! I don't know if you ever resolved your issue but heres what worked for me. First things first make sure it's not running obviously. All you have to do is go into wherever you installed BYOND, typically C:\Program Files(x86)\BYOND.

Go to the bin folder and find the executable for Dreamseeker. Right click on it and go to properties, compatibility, and check off "Override high DPI scaling behavior" and select scaling by "System (Enhanced)".

Then go to the executable for BYOND itself, go to compatibility, and select "Windows 8". I had mine set to XP Service Pack 3 for a while and although it solved the problem you're having now, I got some overlapping text bugs and it didn't fix my windows. Setting it to 8 fixed everything.
In response to AznBanx
Hey this I had the same problem and this worked. Thanks!