Every time I connect to an SS13 server, it downloads resources, plays an ad, whatever, but when it gets to the game it just freezes up and stops responding, with half second intermissions where I might be able to actually click something. I've reinstalled BYOND (both directories), and tried multiple servers.
Often this kind of thing is a result of antivirus or security software going berserk and interfering. What are you using there?

Also there are some SS13 servers that have this problem more than others, and it often traces back to a problem with the DirectX installation. If you reinstall DirectX from the Microsoft full installer (June 2010), does the problem go away?
I'm just using Windows Defender but I've added the two BYOND directories as exceptions now, and I've reinstalled DirectX but the problem still persists. This problem also happens when I run a world from Dream Daemon, so it's probably nothing to do with individual servers.
Check your Windows firewall settings. Are all of the BYOND applications (byond.exe, dreamseeker.exe, and dreamdaemon.exe) allowed full access for TCP?
They are all allowed, the problem is still present.
And they have full access? When the Windows firewall prompts me on something new the default is to only allow access on private networks, and it'd be easy to click that by mistake; if they weren't given full access but only partial, that would be a problem.
Full access, full everything.
Turned off my firewall COMPLETELY, no effect at all. And it's not just SS13, meaning it's a problem with dream seeker and a program or setting on my computer interfering with it :/
This is still an annoying and frustrating problem so help would be appreciated.
EDIT: On what must be my 500th attempt, I did encounter a DreamSeeker error saying "Improper argument" but this might just be this server.