ID:2307588
 
BYOND Version:512.1392
Operating System:Windows 7 Ultimate 64-bit
Web Browser:Chrome 61.0.3163.100
Applies to:Dream Maker
Status: Unverified

Thus far we've been unable to verify or reproduce this bug. Or, it has been observed but it cannot be triggered with a reliable test case. You can help us out by editing your report or adding a comment with more information.
Editing an icon file pointed to by a modified type while a map has changes pending results in that icon filename becoming !INVALID VALUE! when the DMM saves due to a compilation.

Seems like this issue is new to the 512 series. I've run into it as far back as 1389, so it's likely been there since the beginning of the beta series.
I meant to get to this sooner. Can you give me more details on precisely how I can trigger this, step by step?
Looks like this was resolved in the last 4 releases by another fix. I'll let you know if I run into it again. I'll have Nadrew swap this back to open or something if I see it again. For now, unverify it.

Method to reproduce:

You should still have an outdated copy of runegate.

1) Open 'graphics/tilesets/town.dmi'



2) Add a new icon state to the icon file. This will cause the icon file to record a change.



3) Open maps/tilesets/town.dmm (It's not included because it's not a map, it's a tileset.)



4) Create a new turf instance and set its icon to 'town.dmi', and icon_state to the new icon_state you created. Place it on the map.



5) Compile
Lummox JR changed status to 'Unverified'
This is not resolved and should be addressed. This still happens to me on a semi-regular basis and Ter13's description of what triggers it is accurate in my experience.

Seems to corrupt more icons than just the one that was edited, for me it corrupts almost all of them but I'm not sure what the common thread is since some others seem to be unaffected.

Here is what the text file of a corrupted map looks like: https://i.imgur.com/cGdrGkD.png
I ran into this issue about three days ago. I had to edit the .dmm file using notepad change !INVALID_VALUE! to the appropriate .dmi file name. The issue was easily replicated using the steps Ter13 pointed out.
Uhh, all the detail has been compressed out of that image. I can't make out a thing.
you've gotta click it to open it again lummy
In response to Lummox JR
Lummox JR wrote:
Uhh, all the detail has been compressed out of that image. I can't make out a thing.

...Brooo...
In response to Ter13
Aha, it was the frelling mobile site. On my PC I can see the image just fine. The mobile site for some reason doesn't show me the full version.