ID:2373046
 
Resolved
BYOND Version:512.1426
Operating System:Windows 7 Home Premium 64-bit
Web Browser:Google Chrome 66.0.3359.181
Applies to:Dream Seeker
Status: Resolved

This issue has been resolved.
Descriptive Problem Summary:
After updating to the beta client all sprites/texture become invisible with the exception of the top layer of a tile. Other exceptions are Players/Humans/Lizards/Monkeys/etc usually only show their hair, tails, HUDs, or are also completely invisible. Tables & walls show their texture at 1/4 the original size leaving the other 3/4 blank.

Numbered Steps to Reproduce Problem:
1. Grab a Windows 7 ISO
2. Run it in a Virtual Box
3. Update Windows and IE
4. Install Byond update it to beta
5. Join a TG Station
6. Profit? I am at a lost here.

Expected Results:
All textures and sprites to be visible.

Actual Results:
https://imgur.com/a/BQ5ayOa

Does the problem occur:
Every time? Or how often?
Occurs indefinitely on games/servers listed below.

In other games?
Space Station 13's TG Code Servers (Paradise Station is unaffected as it doesn't need/use the beta client's features(etc))

Spires of Agartha is also has this bug most notably on your own character showing exclusively your hair.

In other user accounts?
---
On other computers?
---
When does the problem NOT occur?
Space Station 13's Paradise Station(They don't require the beta client in the first place)
Soul Elysium was briefly tested no issues found.

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked?
---

Workarounds:
No work arounds found currently.

Things I've tried
I've Updated/Downgraded IE to version 6.x and to 11.0.9600.17843

Tried stable and beta versions of Byond however this issue has not stopped occuring since when I first updated to the beta.

Install all important updates for Windows itself

Uninstalling Byond and IE completely and reinstalling them

Information about the VM this was all done in
https://pastebin.com/2DFVnHM7 <-- DxDiag
Anything else can be provided by per request.
This is really odd, so I have to wonder if the problem is something with your virtual machine. Nothing like this has been reported before, and SS13 admins would have been all over getting me news of a problem like this.
This is textbook failure of hardware acceleration to activate. the fact a beta version introduced the bug is odd though.

Keishinu: Go to https://secure.byond.com/download/build/512/ and try different versions until you find the one that introduces the bug, would help Lummox narrow down the offending code change. The .zip versions are best for this since you can skip the install.

You can make this a much faster process by utilizing a binary search process, start at the halfway mark between the first and most recent 512 build, test that version for the issue, eliminating the latter half if the issue exists, and the former half if it does not, rinse, repeat.
I followed your instructions and all of 512 has this issue. I even went back to 511 to test it on Spires of Agartha(Since Tg code requires 512) and had no luck. I also looked into the idea of it being a VM issue and found that Virtual Box has a Guest addition's CD which is meant to optimize the system and add better drivers but that also didn't help.
Woa! You were definitely right about the hardware acceleration I discovered the VM software has its own way of handling hardware acceleration which apparently is a lot better. Thank you kindly
Since it seems your VM setup was the issue, I'll go ahead and close this.
Lummox JR resolved issue
In response to Keishinu
Keishinu wrote:
Woa! You were definitely right about the hardware acceleration I discovered the VM software has its own way of handling hardware acceleration which apparently is a lot better. Thank you kindly

How did you fix this? I enabled 2D acceleration in VirtualBox's settings, but I'm still having the bug.
If I remember correctly installing Guest Additions will fix the issue. All the details are here: https://www.virtualbox.org/manual/ch04.html
Do you just install Guest Additions? No other changing of settings? I'm 99% sure I tried that but time to install windows again... and all the updates...