Yet another hang related to images was found.
BYOND Version:512.1435
Operating System:Windows 10 Pro 64-bit
Web Browser:Firefox 61.0
Applies to:Dream Seeker
Status: Resolved (512.1439)

This issue has been resolved.
Descriptive Problem Summary:
Every time I've tried to connect to /tg/ station 13 on the most recent BYOND build for a good while now, I will experience regular Dream Seeker crashes at a rate of maybe one every 10-20 minutes. Many, many players on the server have reported this same issue, constant Dream Seeker Crashes. However, it doesn't happen on earlier versions of the 512 beta. I was able to reproduce this issue on versions 512.1429-512.1435.
Numbered Steps to Reproduce Problem:
1. Install 512.1435.
2. Connect to /tg/ station and attempt to play (also happened with observers)
3. Crash every 10 minutes and downgrade out of frustration.
Does the problem occur:
Every time? Or how often?
It happens every round. DreamSeeker will crash multiple times in the duration of a ~1 hour round.
In other games?
I've only experienced this issue on /tg/ station 13.
In other user accounts?
Many, many other users have reported this issue to the admin team at /tg/ station 13. As far as I can tell, it appears to be happening to pretty much everyone on these later beta builds.
On other computers?
When does the problem NOT occur?

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? I couldn't reproduce the issue on 512.1428, or any version before that.

Without more info I can't help you. I need details from the crash like the offset where the crash occurred, what you were doing, etc.

This is also the very first I've heard of any crash with 1435, which is surprising since you said other users have reported this to the /tg admins--usually those same admins are quick to let me know about any issues.

The 1428-1434 series however did have known issues in /tg, so issues on any of those builds can be disregarded.
To clarify I am in fact an admin on /tg/ for the time being. I was specifically told by MSO to report the issue instead of just telling players to downgrade. As for details on HOW the crash is occurring, I can make an effort but I'm really not quite sure. I've experienced it repeatedly as an observer, however many, many, many players have told me that it happens to them too in a variety of situations. I guess I will try messing around on 1435 some more and see if I can isolate anything in particular.
The crash details are also important. They may illuminate something useful.
MrStonedOne sent me your minidump for the hang last night. What I do see is that the code was stopped somewhere inside of a call to grab the icons for an image, so this could indicate images caught in a loop. Specifically it's images belonging to a turf, so it's possible that a single turf has its images list messed up.

It is conceivable that my fix for id:2383072 will fix this, especially if you encounter this hang after a big jump.

However, it would be best if at all possible to get me a test case.
Build 512.1436 is out. I added some extra insurance against turf hangs, so between that and the fix for the other issue, I think it's likely this has been nipped in the bud. Please retest the client for that build. (Server build will not matter as long as it's relatively recent.)
Sorry for the confusion about crashing vs. hanging. I've tested 512.1436 for a couple of hours now and I ended up experiencing another hang in similar circumstances. I've got a minidump of this one too, if you'd like it. As far as a test case goes I will try to replicate it locally instead of on the server and see if I can get it to happen consistently.
Try retesting in 512.1438 once that's out. The sanity checking I added ended up making it easier for the hang to occur, and as a result I was able to isolate the problem from a test project.
I updated to 1438 and now *I* got a crash on wine. From following someone as a ghost who was going up an elevator. (zlevel transitions). First one I've ever had in a long time.
I'm reverting back to 1437 and following people around some more to see if it repeats or if it was just a freak occurrence.
No crashes on 1437 yet, both playing and following a spastic AI eye over a multi-zlevel station map
In response to Amidaychi
1437 definitely had the turf image hang issue, so downgrading is not a solution.

If you're getting an actual crash though, that's a separate issue and needs to be reported along with all the crash details; the report here was actually for a hang and all the info available says it was the turf image hang.
Speaking of hangs, I got another DreamSeeker hang on 1438. Again, I have a dump of it. It's a lot less common now compared to 1435. Still not able to produce a test case.
Gah. Please do send me your new minidump and I can take a look. I would think it unlikely that the turf image hang is still in play, but who knows. Your last dump showed that to be the case so if this one does too, then it must still be there. But darned if I know why.

Of course it generally helps to keep track of everything you were doing right up before the hang, like what commands you used and what effects they had (e.g. moving you to a new part of the map), whether you started moving east or west after that, etc.
This does still seem to be an image-related hang. The new trace shows a hang in AddAllPendingCimages() which used to be the favorite hang spot, but I'm confused as to why this could happen anymore. I'll definitely need a test case, so be vigilant about copying down all the details you can to see if something jumps out.
Lummox JR resolved issue with message:
Yet another hang related to images was found.
Thanks to the excellent demo from MrStonedOne I was able to track down this issue and put it to rest. The problem wasn't strictly with turfs and was therefore evading logic intended to sidestep issues in that department. What happened was that some images were being added to the pending list more than once, and were not being removed from the pending list when switching to a turf loc.