When trying to update to beta version 512.1450, it downloads the update, then does the usual UAC of do you want to allow the program to modify data. I say yes, then get a message of ERROR: "Dream Seeker is currently running. Please close Dream Seeker and try again"yet, when I go into the task manager, nothing related to BYOND aside from the installer itself is running. Even when I click retry several times to get to the 3rd error message, saying "Error: Dream Seeler is currently running. Shall I kill it for you, losing unsaved data?" and say yes, I get a "Could not kill BYOND (maybe another user is using it?)-installation aborted." message. I'm the only user account on my computer, and have tried to install this over several days, and thus several restarts of my computer, so nothing should be using BYOND in the background aside from the installer itself.
What version are you currently on?

You can always try soft-updating to see if that does anything, where you just copy the program files from the .zip over the ones in C:\Program Files (x86)\BYOND\bin. If that doesn't work then something else is causing the problem, which you might be able to investigate with Process Explorer.
Current version is 512.1448. And I've tried several times to search through the process explorer, and have gone through ever running process listed, none of which aside from the installer itself has anything to do with BYOND, dream seeker, or any related processes.

As for the soft updating, what .zip are you referring to? I've always just clicked the big red update button on the client window, and beyond that the procedure is automated, and I never see any files or .zip myself.
You can download a .zip file from the download page and install manually from that by copying files.

If no BYOND processes are running the error could indicate a permission issue with Dream Deploy. But hopefully a manual update will fix it.
So I think I found the issue. For whatever reason, my computer is outright refusing to provide access to random files in the bin folder to be replaced. Some files replace fine after being given access, others ask for access, I give them access, same as all the rest, yet will still say they don't have access, but only give me a cancel or try again option, instead of the continue button with the little UAC shield.

No idea what's causing this, as like I said, some files in the bin folder (trace.bat, fmodex.dll, and all the .exe files except dreamseeker.exe) transfer over after asking for admin permission, while others (dreamseeker.exe, and all the .dll files except fmodex.dll) also asked for admin permission, but even after being given permission, still failed, and said they needed permission.
Got it working. Had to restart my computer for something else, and decided to download the .exe installer for the newest beta version before I ded, and ran that first thing I did, and it worked. It seems that for whatever reason, once the dreamseeker service starts, it hides itself in the background and never turns off. Probably explains why Malwarebytes often flips out about it. Could only find the process by going into the full detail mode on task manager, and sorting through that, and even then it said I didn't have the access to shut it down... Through the task manager on the only account on the computer.
Dream Seeker is not a service; it should never be hanging out in the background if it has closed normally. However if any antivirus had flagged it inappropriately, it might have locked files in an open state.
No idea. All I know, is that when I ran the updater, it closed the BYOND client before starting the installer, but the Dream seeker process, which isn't normally active, appeared in the background, only visible through the "Details" tab of the task manager, and refused to shut down, claiming I lack the permission to do so. Anti virus shouldn't be flagging it, as it's never mentioned anything of the sort, aside from Malwarebytes, but I've added the entire BYOND folder as an exception to it's scans, so that as well shouldn't be quarantining the process.

Whatever the case, It's fixed now, as I had to do a complete reinstall anyway, due to the partial .zip update rendering the game completely unusable, and the same access restrictions preventing me from even deleting the BYOND Bin folder from my computer at all.
When you can't shutdown an application from the details tab of the Task Manager (that's really the only tab that ever matters), it always means something with high-level permissions such as security/antivirus is using it and won't let go.