So I've come across this issue where byond can't open because it says it can't find byondwin.dll. This message started happening after I closed a game and tried logging back in. I uninstalled and removed the files then tried to reinstall and the message popped up again too, again saying it can't proceed to download because it can't find byondwin.dll
Can't proceed to download? That's quite wrong.

What does the exact message say? Do you have a screenshot? Do you have a list of files in the BYOND install directory as well?
I've had this happen to me before a few times (all a couple of years ago) on windows 7, I was never able to figure out why. Only solution was to just delete the byond folder in program files (x86) or reboot.
Sounds like antivirus/security flagged the file incorrectly and got it stuck. Since the installer requires admin privileges it should have no issue writing.
Access denied often happens if the file already has a write handle open to it.

googling around suggests there are a variety of stupid reasons this can happen, all of them solved by hoping for the next update to fix it or reinstalling windows.

I think this might just be one of those annoying windows bugs relating to shadow file handles being left around. For some time /tg/ had an issue where the update staging folder would randomly become a undeletable unopenable file that then went away after dd was restarted, It was randomly fixed in some windows update.

Endofhonor: have you tried rebooting the computer then running the installer?