(See the best response by Lummox JR.)
Descriptive Problem Summary:
=== 1 Games do not run from pager (the page after you login, with lists of games and servers)
Instead it returns a generic error :
// C:\Program Files (x86)\Byond\bin\dreamseeker.exe
// "byond://" -pager
// Could not run dreamseeker.exe. Perhaps you should reinstall BYOND?

which I just write down the url part of the error, and open dreamseeker.exe that IS IN THE SAME FOLDER, as the BYOND.EXE client is running from.

// byond.exe ByondStub.dll dreamdeploy.exe mfc120.dll trace.bat
// byond.exe.bak byondwin.dll dreammaker.exe msvcp120.dll
// byondcore.dll dm.exe dreamseeker.exe msvcr120.dll
// byondext.dll dreamdaemon.exe fmodex.dll npbyond.dll

are all the files in the directory. I've uninstalled, deleted the directory, and installed again with restarts, as well as add both .EXEs to MalwareBytes exclusions, as well as the entire directory with no luck.
However, I can connect to a server without any issue, this has only been tried with Space Station 13.
Is there a way to configure how the files are pointing at each other? I believe I read something before on something to change in the registry, but I want to be sure that's what I need to do here without messing up something critical.

=== 2 Pop-up window behaves erratically
Before I used to get the white screen of doom like I've read from a lot of similar posts, and I believe I fixed that by clearing out the cache from Microsoft Edge, the new Internet Explorer apparently. But my issue also has the window snapping back and forth on the right side of the screen to just a little off the center of the screen. This happens when you try to drag the window or if you happen to move your mouse 1 pixel at all when you are trying to click X to close. It will begin "snapping" back and forth, center to right, and you can't reach the X to close and have to default to using alt+f4 to close the window, only to have it still stuck there the next time you open it.
Numbered Steps to Reproduce Problem:
== 1
Open Byond.exe, login, go to games list, select server, click join, receive error.

About a 50% chance of happening each time I use the window, and try to select close. Happens 100% of the time after that.
Code Snippet (if applicable) to Reproduce Problem:

Expected Results:

Actual Results:

Does the problem occur:
Every time? Or how often?
== 1 Every Time, == 2 50-100% of the time
In other games?
In other user accounts?
On other computers?
Should try it on my laptop since it runs Windows 7 still

When does the problem NOT occur?
When I'm not using the client.
Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.)
I did not know there were old sources to use, is there a clean way to uninstall byond without involving a crowd-favorite system restore?


Thank you for your time.
Best response
Moved to BYOND Help, since this is not a bug.

The problem is obvious from your report:


The .bak extension is used by some editors, whether text editors or other, to hold a backup version of an edited file. It shows something extremely non-kosher was done at some point, either by you or by another program on your system.

You say you've uninstalled and reinstalled numerous times, but an uninstall should have nuked that folder. So it seems some kind of weird permission issue is in play. I would suggest uninstalling, nuking that folder manually, and then reinstalling.