A couple game servers require the beta version of BYOND to connect, so I tried to upgrade to it. But I've been having persistent trouble, every time I try to extract the ZIP file it runs into an error saying I don't have access, but only for Dreamseeker.

I somehow managed to get it to run last night for long enough to connect, but this morning when I tried to connect to the same server again Dreamseeker had deleted itself.

I've tried giving it administrator permission, and it just goes into an endless loop of "You need permission to do this, try again?"

Really at a loss here.

Running on Windows 7, if that's at all relevant.
Sounds like your antivirus has triggered a false positive and is quarantining the file.
Funnily enough, I ran a virus scan on the ZIP and it didn't find anything. I managed to unzip it successfully again and connect for a while, and then once again dreamseeker deleted itself the next time I tried.
Huh, checked my virus chest and that was it, guess I'll submit this as a false positive.