Descriptive Problem Summary: I can't hear any audio coming from any Byond game since yesterday (30/10/2018). It worked fine before. (

Numbered Steps to Reproduce Problem: I don't know. It stopped working like that. Without much reasons that I know of.

Code Snippet (if applicable) to Reproduce Problem:

Expected Results: Hearing audio in Byond Games (especially Space Station 13)

Actual Results: No audio heard at all in any Byond games (altough the Byond sound effects on the main byond app still work, not on dream seeker)

Does the problem occur:
Every time? Or how often? Everytime since yesterday.
In other games? Every Byond games
In other user accounts? It occur to all user accounts (including guest mode)
On other computers? No idea, I assume it's only my computer having that problem

When does the problem NOT occur? Never

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.)


You might want to try updating to the byond beta, latest version, it's very stable and has a ton of performance and bug fixes.
Thanks for responding. I have the latest Byond beta version (I also have the latest stable version). But yet sound don't work for me.

Here's some infos I can give already:
- Sound work fine for everything excepted Byond games
- My computer OS is Windows 10
- I'm playing with an MSI laptop
- I checked the sound mixer, tried to mute and unmute dreamseaker when I'm on it, no matter what I do sound don't come back
- Yes, "Downoald graphic and sound" in preferences is ticked
- Byond is updated to the latest Beta version
Moved to BYOND Help because this isn't actually a bug; it's a sound driver issue. BYOND is usually the canary in the coal mine when it comes to sound driver problems. I would try updating your audio drivers.
I tried to update my audio driver (Realtek High Definition Audio), but it was already the latest version of the driver. Don't know what I should do.
Others games (steam and non steam) audio work normally (excepted Rimworld on steam, which worked perfectly before), if that's any indication

I really don't know what to do
I would rick click the little sound icon on the botton right of your desktop window, then hit volume mixer and see if dreamseeker is turned off.
Thanks for the response. Already checked multiple times, dreamseaker is always at 100 on the sound mixer. Tried to mute/unmute it aswell. Doesn't work sadly.

It might be a driver issue so?
reinstall byond completely, if not try deleting your audio drives and just replugging them and let them auto update
I reinstalled Byond twice, altough maybe I missed some files. I deleted the Byond folder in Programs and the Byond Folder in Documents. So I don't know if I fully uninstalled everything.

I'll try deleting my audio drives. Did it earlier but it did not seem to work.
Some additional infos: I'm on a MSI gaming laptop, here are the specs:

Processor: Intel(R) Core(TM) i5-7300HQ CPU @ 2.50GHz 2.50 GHZ

RAM: 8.00 Gb (7,89 available)

OS: Windows 10 Home 64 Bits Processor x64
In your Realtek control panel you might look for other audio outputs to see if they're muted or on a low volume. Maybe one of them got muted for some reason.
Thanks you all. Sound came back somehow.
It's highly possible that something was muted in Realtek control panel, altough I'm not sure, because after I messed up with it a bit sound came back somehow.
Hope this will help others with a similar problem!
Sorry for the bump, but I think this is important for anyone who have a similar problem.
I found out my issue was that audio enhancements were activated automatically. Normally if you troubleshoot your computer audio, it'll prompt you to remove audio ehancement, but if you have a MSI like me it will not work, you have to open Nahimic and remove audio enhancements directly from there. Hope it'll help people's out