Not a bug
BYOND Version:512.1455
Operating System:Windows 10 Pro 64-bit
Web Browser:Edge 42.17134.1.0 Microsoft EdgeHTML 17.17134
Applies to:Dream Seeker
Status: Not a bug

This is not a bug. It may be an incorrect use of syntax or a limitation in the software. For further discussion on the matter, please consult the BYOND forums.
[continue from version] from the download page. Can't see the version because it conveniently doesn't say what the version is on the home screen, right where it says it's the latest version. But wait, if you wonder why I didn't check the about byond page for the version, that's because BYOND scales like sh*t (that is, it doesn't scale at all) on high DPI monitors and so I have to increase the zoom, which means I can't read the version on the about byond popup window because it crams too much in a tiny window you conveniently cannot resize.

Descriptive Problem Summary:
Mouse left click only refuses to work for random reasons on different systems.

Numbered Steps to Reproduce Problem:
Random or too many variables to tell.

Code Snippet (if applicable) to Reproduce Problem:

Expected Results:

Works properly.

Actual Results:

On both laptop with touch screen and touchpad and mouse, and PC with mouse:
Left click randomly bugs out usually when opening an SS13 game, (don't have the patience nor time to test random bugs on other byond games), but also happens randomly in the game.
That is, just left click on the map/game/graphics pane, while right click works(then left click to select an option from the menu). Chat pane loses mouse wheel scroll too. The rest of the basic UI works, such as changing tabs, clicking verbs, etc.
A symptom of this happening is that the mouse pointer becomes the I for typing or the parallel lines with arrows for resizing the window and gets stuck like that. Passing the cursor over the respective source, for example when it bugs out as resize, pass it over the resize separator, fixes it but it still doesn't work and bugs out again in a few seconds.

Disabling touchpad and touchscreen devices doesn't work either (with USB mouse plugged in). Restarting with them disabled doesn't work either.

Does the problem occur:
Every time? Or how often?
Random, in the sense that without changing devices or editing anything it just happens.
In other games?
When I tested this a long time ago and managed to fix it by forcing restart with byond open, I believe it also happened in other games.
In other user accounts?
On other computers?

When does the problem NOT occur?
Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.)

I do believe it's some update within the last half a year or year. Never happened before on anything.

Restarting with byond open used to fix it but not anymore as of this version, and only on some computers (laptop restart this version didn't fix it, only PC restarting this version fixed it).

Moved to Beta Bugs in case this is a beta issue, but dude, you really need to edit that version field. That's not meant for a novel. Additional comments go in the post body.

If this is something that restarting your computer fixes, this is very likely a system issue though and therefore would actually belong in BYOND Help. I would strongly suggest doing a thorough virus scan in case something is eating those mouse events.
Yeah, I've run virus scans. I'm certain it's not a virus. Restarting *used* to fix it.
Now, ever since I posted this, I haven't had any problem.
I don't know how a system issue could present itself on two different computers. The common things are just the same network, same byond account and same windows version (I guess with same edge/IE version but god knows what the dotards at microsoft are doing).
You can close this bug report as the topic has since been renewed in a new thread in BYOND Help and I'll post any updates on there.
Lummox JR resolved issue (Not a bug)