BYOND Version:N/A (Website Bug)
Operating System:Android 5.1.1
Web Browser:Latest version of Firefox for Android
Applies to:Webclient
Status: Open

Issue hasn't been assigned a status value.
Descriptive Problem Summary:

When I try to connect to DW: SOE using my Android tablet in Firefox, it gets stuck loading the game (and it doesn't load ads either - probably the cause, despite no ad blockers being installed on the device)

Numbered Steps to Reproduce Problem:

Tap the link to play with webclient on SoE's hub.
Wait forever for it to download resources completely. Doesn't even get to launching the game, just sits there in perpetuity.

Code Snippet (if applicable) to Reproduce Problem:

Expected Results:

Loads the game.

Actual Results:

Never finishes loading. ~20-30 MB download of resources, including sound and music (no option to not download those, can only disable them after it loads)

Does the problem occur:
Every time? Or how often? Every time
In other games? Haven't checked
In other user accounts? N/A
On other computers? Webclient doesn't work on my Android phone (version 7.0 of Android and running the exact same version of Firefox my tablet is) either, and the phone blocks ads. The ad container partially loads on my phone, but never loads an ad and never progresses to the game. Using AdAway (hosts file ad blocker). Haven't tried it in Windows Firefox because I use the latest BYOND client for Windows.

When does the problem NOT occur?

Before version 512 of the webclient, my tablet was able to successfully download and connect to SoE. It had the same setup it does now. Didn't load ads despite having no ad blocker installed, yet it actually finished downloading and launched the connection to the game.

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.)


Only using Windows BYOND client. Webclient doesn't want to work on Android/Firefox.