I click the Byond shortcut but it doesn't react
Do you see byond.exe appear in the Details tab of Task Manager?

Is this a new installation or have you been able to use this in the past?

Do you have any antivirus that might be interfering by mistakenly throwing a false positive?
I have something similar happen. I attempt to open it, but it does absolutely nothing. I get nothing from antiviruses either, so I have no idea what the issue is.

Just an edit with a possible fix: It shows up in task manager and is capable of opening normally if you end the process and attempt to open it again.
I have the same problem, nothing happens when I try to open it and there is no byond.exe in task manager to stop.

I have the same thing, stable 512 build works just fine but 513 beta build refuses to launch.
In response to FkAA
Do you have any crash reports in the Windows event viewer? And what system is it running on?
I checked and I do, and I run Windows 7 SP 1. I tried to run it with compatibility mode without any different results, and also when I try to run it, I don't get any error message, it just 'loads' and that's it, nothing new in the task manager and all. I have the Polish language so I will try to translate the log:

The name of the application causing the error: byond.exe, version: 5.0.513.1491, timestamp: 0x5db20b97
The name of the module causing the error: byond.exe, version: 5.0.513.1491, timestamp: 0x5db20b97
Exception Code: 0xc0000005
Error shift: 0x0001fcc5
The identifier of the process causing the error: 0x14b0
The time the application that caused the error started: 0x01d58b2580d54d7b
Faulting application path: C:\Users\User\Desktop\byond\bin\byond.exe
Fault module path: C:\Users\User\Desktop\byond\bin\byond.exe
Report ID: c084764d-f718-11e9-b5e6-74d435d7449a

EDIT: I forgot to mention that I use the zip version of both, not the installer.