When i try to join a game,my scroll wheel stops working no matter what application i'm in, all buttons on byond and some on other applications don't work, and its stuck not joining until I close the byond window. Is there any known way to fix this and have any of you experienced this before?

I've already used beta branch, cleared cache, and reinstalled and none of those worked BTW.
I have the same issue. It returns to normal by itself after a while but I get a dreamseeker.exe crash in the Event Viewer. Do you get one too? See Event Viewer -> Windows Logs -> Application and find the most recent Application Error.
Event viewer crash details will be very important for determining the problem. If you can post those I may be able to find something.
Faulting application name: dreamseeker.exe, version: 5.0.513.1501, time stamp: 0x5ddeaa66
Faulting module name: ntdll.dll, version: 6.1.7601.24384, time stamp: 0x5c6e2180
Exception code: 0xc00000fd
Fault offset: 0x0002ed07
Faulting process id: 0x3c0
Faulting application start time: 0x01d5a9bc9616b443
Faulting application path: E:\513.1501_byond\byond\bin\dreamseeker.exe
Faulting module path: C:\Windows\SysWOW64\ntdll.dll
Report Id: fe389ead-15af-11ea-b5ee-e839356142b4
That crash is a stack overflow, so the only way I'll be able to investigate further will be if you can get a minidump (Windows error reporting typically generates those automatically) and send that to me, as long as it's not more than a few megabytes. With that I might be able to get a stack trace.

However, because this is a stack overflow it's possible that the stack trace won't go back far enough; the only way to tell is to examine the dump file.
I can't seem to get a minidump, it just doesn't generate it or says it did but there's nothing on that path. Other applications seem to normally generate a minidump but I don't think they're having stack overflow errors.
I got this stack trace by running dreamseeker.exe in some debugger program. I don't actually know what to look for so here's an image:
That does look very useful, because I see there are two routines in dreamseeker.exe pingponging off each other. However I'll need to know where dreamseeker.exe was loaded in memory to be able to put that information to use. Any way you can get the info on where the various modules were loaded?

(The reason I need to know where they were loaded is because the addresses you have in that stack trace are absolute, whereas I need to know the offsets from where dreamseeker.exe begins. With that information I can figure out which routines those addresses correspond to.)
Sorry for the late reply!
The larger address is at 52A5D while the smaller one is at 503E1.
This appears to be an infinite recursion loop between two functions in dreamseeker.exe, but I haven't yet figured out the exact circumstances behind the recursion. I think I'll just stick a dirty recursion check in there to handle these cases.

The issue will be fixed in 513.1503.
I have litterally the same issue. Yet I updated to 513.1503 and it still loops.

Here's the event viewer log :

Détecteur d'erreurs 1566016005075068166, type 1
Nom d’événement : APPCRASH
Réponse : Non disponible
ID de CAB : 0

Signature du problème :
P1 : dreamseeker.exe
P2 : 5.0.512.1488
P3 : 5d94fd6a
P4 : ntdll.dll
P5 : 10.0.17134.1
P6 : c8733c73
P7 : c0000005
P8 : 0003aaed
P9 :
P10 :

Fichiers joints :
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERDC4A.tmp.WERInt ernalMetadata.xml

Ces fichiers sont peut-être disponibles ici :
C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_ dreamseeker.exe_3be28b9cdbb435ff47f41794af776df63ba1412_1e79 cc73_1e64e0fc

Symbole d’analyse :
Nouvelle recherche de la solution : 0
ID de rapport : 3d769af4-c3f2-4644-841c-ef79d4641ce7
Statut du rapport : 268435456
Récipient avec hachage : c174b4eeb25dc9de15bb9b426f136506

In response to Ludox235
Not the same issue. The exception code ix 0xc0000005 (access violation) whereas the one that was discussed earlier was 0xc000004d (stack overflow).

If you can grab that .dmp file that's listed in that text, and it's not huge (e.g. if it's only hundreds of megabytes), you can zip it up and send it to me and I'll take a look.
I checked in the folder and there's no .dmp file in there, only .xml

Would sending those help you?
In response to Ludox235
No, I need the .dmp file. It probably got erased after a while.

The problem is your crash is happening in a .dll that isn't one of ours, so the only way to figure out the problem is to look at the program's stack. A minidump file will have that information.

Try opening it again and see if the .dmp is created this time. If it is, copy the .dmp file (assuming it isn't huge like 100 MB or something), zip it up, and send me a download link.

Also I'll need to know which version of BYOND goes with the dump file. I see your post said 512.1488, so I can assume that unless you update.
By the way, I still can't play games on my computer because the game window can't start (the options and messages window is just hiding and unhiding itself in a loop). But the focus stealing issue is fixed by the update.
In response to Ajmo malo
I can't figure out why the O&M window would be looping like that, especially after the 513.1503 update which specifically fixed it. Perhaps you could get some new debugging data that might shed light on the issue.