BYOND Version:513.1508
Operating System:Windows 10 Home 64-bit
Web Browser:Chrome 79.0.3945.130
Applies to:Dream Maker
Status: Open

Issue hasn't been assigned a status value.
Short story : The bug is that a null maptext prevents the text variable from being used properly when there are atoms with icons.

More details :
If you have icons and enable text-mode, you get a black screen, when it should instead show the first letter of the name of the atoms.
Giving mobs a maptext allow text-mode to work.
Giving everything except the mobs a maptext don't allow text-mode to work.
Giving the mob an empty maptext don't work.
Giving the mob 'maptext = " "' allow text-mode to work without actually showing text in sprite-mode.

Commenting out every icons also work, but as soon as there is a single icon, it would stop working.

Thanks to 'Echo' on the discord for helping me with this problem and 'Mr. Goober' for suggesting to use maptext in the first place.

Here's the demo, comment out 'maptext = " "', then turn on text-mode to see the bug :!J8wWnQiJ!NijPxIqrctWJGK_JlAJ3YDLGKeu-WjSzR SookLYLeJ0