Since I fixed my PC and got Win10 installed I have had this issue where Dreamseeker just shuts itself after trying to joining a server (mainly SS13 ones). Dreamseeker downloads resources just fine but when the loading/ad screen tries to transition to the actual game screen it closes itself and not sure what is causing this.
For context:
Green is the dreamseeker loading/ad screen
Red is the dreamseeker trying to open the game, which for somer reason starts suspended while looking in the resource monitor. After 2 or 3 seconds, it closes both of the dreamseeker exes.

I have tried everything at hand: Checking the antivirus I installed and Windows Defender, firewalls, turning the router on and off, running BYOND and Dreamseeker as admin, checking IE settings, trying to connect using byond//: links, cleaning my cache, re-installing BYOND. (My current version is 513.1520) and nothing seems to work.
There has to be something on your system causing this. Are you seeing anything showing up in your Windows event viewer from around the time you tried to start the program? That should give you some information.
Ok, found a way to fix this. Had to launch BYOND and Dreamseeker with Win 7 compatibilty and it worked.
i had the same problem as GoodGuy & fixed it the same way but now I don't have the chat window on the right side of the screen in ss13