It seems completely out of no where suddenly the game decides to not connect to the hub telling me "The BYOND hub reports that port 13370 is not reachable." when players can log in and play.

All the tests and pings have been done, the port is open and I don't know why I still get "The BYOND hub reports that port 13370 is not reachable."

Is there something somewhere causing this within the linux installation?

I'm currently using the latest linux release BYOND put out for 513 thinking maybe updating it would help and no luck, I have even checked DreamDaemon -version and verified it is running the latest.

I thought you said this was solved by removing the hub password. If you change it to something else and recompile your game with the new password, does the problem persist?
In response to Lummox JR
So removing the hub password allows the project to show on the physical website (with drastically less players than should be advertised) but not the program.

Tried with a new hub password I still get "The BYOND hub reports that port 13370 is not reachable." but now it doesn't show on the website either.

(Yes I changed the one on the hub to match)
This highly suggests a network issue with your host, and not something on BYOND's end.

If something like iptables is being used to route traffic in different ways it could effect this, anything acting as a firewall can, really.
In response to Nadrew
It's a linux server running the Gentoo OS I haven't changed anything recently it just started happening out of no where really, would you know of anything that could be changed? I don't object to the idea it's something within the server I just don't know where to look.

NFO servers tell me there's nothing set up to block any connections.
It could be a number of things between your server and the BYOND servers, you need to trace where the failure is happening before anything. NFO can probably help you with that.
In response to Nadrew

Would there be anything there causing the issue? Not well versed in networking. The server is joined with the IP address of course.

NFO refuses to believe anything is their fault so I'm not getting the help a customer should get.
Might wanna try something like a tracert to the BYOND hub servers.
In response to Nadrew right?
In response to Bustercannon
Since pinging works and joining the game is possible (both of which use TCP iirc), but traceroute (which uses UDP) doesn't seem to reach the hub ip, could it be possible that the hub is trying to reach port 13370 through UDP when it gives that error?
Using the TCP flag in the traceroute command seems to make the byond hub server respond:

traceroute -T
traceroute to (, 30 hops max, 60 byte packets
1 ( 0.208 ms 0.167 ms 0.126 ms
2 * * *
3 * * *
4 * * *
5 * * *
6 * * *
7 * * *
8 * * *
9 ( 20.033 ms 19.767 ms 20.700 ms
Very curious.
In response to Nadrew
Looks like it's making it, as Lummox noted in the other thread you may want to try getting rid of the IPv6 stuff on your eth0 interface. It might be confusing BYOND (which doesn't support IPv6, although it SHOULD)
Found a way to disable it, going to test it out.
In response to Nadrew
I did some research and tried editing a file called "sysctl.config" and added the line

net.ipv6.conf.all.disable_ipv6 = 1

This did not work at all, there's also nothing enabled in this file.

I've played around with the google research and I've had no luck adding/removing lines rebooting the server and trying it all out just to have a live server that can't access the hub.
In response to Nadrew
So it seems ipv6 is disabled via multiple files and checks on this new OS I installed, I'm running Debian 10 now.

This was a fresh install to attempt to fix this issue and no luck, ipv6 is disabled and no luck, are we sure the IP isn't banned somehow?

This problem happened out of absolutely no where while it was working correctly on the last OS.

Let it be known by removing the hub_password I can be shown on the hub's website but still not on the program.
If it's showing up on the website, then it'd appear within the pager too. They're getting the data from the same place. If you're not seeing it there, it's likely something unrelated on your end within the pager itself. It's been known to be a bit sluggish/unreliable at pulling the player data from the hub in the past.

And the fact that changing the hub_password changes the behavior means there's no ban or restriction in place on the IP level.

You should also keep in mind that the player list isn't realtime, it's delayed and cached. Joining and leaving the game won't cause the list to be updated immediately, it can take upwards of 10 minutes.

The message you see about the hub being unreachable is triggered when the game connects to the hub and the hub fails to return a proper response. Usually this only happens if the port/IP combination is unreachable. But since people can join this is obviously not the case.

So that points at something else causing an issue in the communication process, and since you're having some clients get reported and not others when the hub_password is disabled it means it's something intermittent that's not happening every time, but perhaps enough of the time to prevent the initial security check for hub_password validity to succeed. I believe if the validity check fails it won't try further and just assumes the game won't be talking to the hub from there out.

So I have a feeling it's some kind of odd off-and-on failure to properly talk to the hub, and perhaps one that's causing your hub_password check to fail and prevent further communication. Without a hub_password, it'll just freely send the data as it's able, and from the sounds of it only a fraction of the data is getting through.

The next steps are using a packet monitoring tool to determine where the failure is happening, you'd be able to see if the outgoing packet was reaching the destination and whether the incoming packet from the hub was arriving back in a timely manner.

Have the players that are in the game been experiencing any strange connection drops, or above average latency or anything unusual like that?
Everything has been running beautifully, it's literally just not showing as live. Whenever I boot up I get "The BYOND hub reports that port 13370 is not reachable."

Actually I can still effectively communicate with the scores and medals on the hub too, with no drops.

How would I go about getting a packet monitoring tool? Is it something integrated into the Debian OS or something external?
Page: 1 2