BYOND Version:513
Operating System:Linux
Web Browser:Chrome 83.0.4103.106
Applies to:Dream Daemon
Status: Open

Issue hasn't been assigned a status value.
Descriptive Problem Summary:
Numbered Steps to Reproduce Problem:

Code Snippet (if applicable) to Reproduce Problem:
DreamDaemon BLN/BLN.dmb 13370 -trusted -logself &

Expected Results:
Hosts a live server through linux.
Actual Results:
Does, but doesn't show on the hub.
Does the problem occur:
Every time? Or how often?
In other games?
Decided to run a test project with nothing but the hub credentials and it had the same result, there was absolutely nothing in this project other than the world definitions.

In other user accounts?
On other computers?

When does the problem NOT occur?
When I host off of my connection or something that isn't on this linux server. I had plenty of help from NFO to determine it wasn't on their end via forum link at the top.
Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.)
Version had nothing to do with it as I had a perfectly fine server in 512 linux version where it randomly occurred one day. Updated to 513 to no avail.
You tell me lol.
The fact that this only occurs on the one server indicates it isn't a BYOND bug.
In response to Lummox JR
Is there anything you would suggest I try? Are there any linux settings that could bother this interaction?

Better yet what exactly am I facing? What is the connection to the hub broken down? Apparently it has to be something in the OS but it's a mystery to me as to what.
In response to Bustercannon
I'm the wrong guy to ask those questions of. You were on the right track posting in the Linux help forum.

I have a slim hunch here that maybe the host has some weird settings regarding IPv6. BYOND does not support IPv6, so it's conceivable the hub is seeing a different IP than the one that ultimately gets shown to players to join.
It's just weird that this happened out of absolutely no where while things were working fine.