ID:259693
 
Since I've used the statpanel, I think instead of this:
mob/Stat()
statpanel("Blah")
stat("Blah","Blah")

It should be this:
mob/Stat()
statpanel("Blah")
stat("Blah","Blah")

This way, it's more organised, so it is easier to see the statpanels easily, though this is only something minor.

Unknown Person <<
I agree with this one. It would make things more organized, and I can't see any reason why you wouldn't want to change to this system. Does anyone else?
In response to Polatrite
Its looks the same to me x_x
In response to Polatrite
I can't see any reason you'd use either one!

if (statpanel("Blah"))
stat("Blah","Blah")

is better because it incorporates both the more organized presentation and it prevents the game from processing commands whose results aren't seen anyway!

If you don't use the if() statement, it's generating all the statpanels every call of Stat(), not just the ones you can see.

So given that there's a way to do what's being requested, which also cuts down on the processor load, and given that allowing

statpanel("Blah")
stat("Blah","Blah")

would likely require some mucking around with the architecture of procs within in BYOND, I don't really see the benefit here.

Of course, they could revise it so that

statpanel("Blah")

includes an implied conditional statement, but that would mess up a lot of existing uses of the code.