Code: A simple macro
In a dms file I have:
+ return "Toggle-default-action"

And in my code file I have:
set name = "Toggle default action"
set desc = "Allows you to switch your default command between say, emote, OOC and guild say (if you have it)"
set category = "Options"
(And the code goes on from here)

Problem description: My problem is that, while the verb works, I can NOT get it to set the macro of that verb to +. Or a or space or any other button for that matter.

EDIT: Oh I forgot to add that the message I get says there is no macro defined on that key. Also of note is that I have tried "Toggle default action" and "saytype" as other options for the macro, but it doesn't work.

set name = "+"
return "lol"
In response to DivineO'peanut
That doesn't work either. :|
In response to CaptFalcon33035
That's because the name of the macro is 'Add'.
return "Something"

List of macros
In response to Nadrew
Dang! I was just 'bout to do that. I used Hiead's Macro Finder. =D

Hiead's Macro Finder

Very useful.
In response to CaptFalcon33035
CaptFalcon33035 wrote:
That doesn't work either. :|

Eh? 'course it does. I tested it.
In response to Nadrew
Nadrew wrote:
That's because the name of the macro is 'Add'.
> macro/Add
> return "Something"

List of macros

That helps a lot, thanks!
In response to CaptFalcon33035
Oddly, whilst I've tried both things... it still doesn't work. I'm beginning to think that it's got something to do with my computer, since macros that other games supposedly have don't work for me either...
Are you holding the ALT key or do you have the macro switch enabled in the Dream Seeker client?
In response to DivineO'peanut
Oh yeah? Which key do you have to use for it to fuction, and where on the keyboard?
In response to CaptFalcon33035
I've tried both, and neither work. The only thing that works is if I define my own macros within Dream Seeker, which will then make it work. Otherwise I either get nothing happening, or a message that says "No macro defined for '(key)'"

Make sure your macro is formatted just like that, in the DMS file. Then, make sure "Something" is replaced with the name of a real verb, without the ().
Are you setting client/script somewhere in your code?

client/script overrides DMS files if it's set to anything. A library might also be setting it, so check that too.

There's an easy way to test this; add in this verb and see what it is:

if (!client) return
if (client.script) src << "client.script is overriding your DMS file!"
else src << "client.script is not set"

Also make sure that the DMS file has a checkbox next to it in Dream Maker.