ID:2641927
 
Some months ago i successfully installed and ran byond thru wine on Fedora linux.
After some updates and so i tried to run it again but now i am getting this error when i try to run it:
`...\My Documents\BYOND\pager\custom\alert-corner.png contains an incorrect path`

I checked my wine configuration and also whether the files exist, wine config "My Documents" points to the corrects path which does contains the files required.

I have no idea what the error is. I tried reinstalling the newest byond client. My wine is also about some of the latest.

Image: https://pasteboard.co/JEB99hv.png

Where does the BYOND directory containing resources actually come from? i don't think it got installed after i installed byond this time.
I don't think it likes running on the latest version of WINE. I reverted to the second most recent and I managed to get past that issue. Then followed more. https://bwo.ink/ has some info on fixes that worked for me in the past, but I've not managed to get it working when I tried today.

If you get stuck loading BYOND; I managed to get past that and into the game, but then my chat stopped working and I don't think IE is working properly for me (UIs are janky). I made by architecture 32 bit, got all the winetricks from the aforementioned site and then it worked fine bar the chat issue that I've not been able to resolve which made it unplayable. For some reason I can see the chat working perfectly fine for like half a second when I get in and then it stops.

If you manage to get past it and fix it somehow, please update me. Sorry about the late reply, good luck.

P.S. Nice name.

EDIT: I've also got my wine config in XP, not sure if it changes anything though.
Tried to recreate all my listed steps to get SS13 working in the same state as before so it could be diagnosed. Instead I've broken everything and now I am abandoning ship (Fedora 33) and swapping to NixOS. Going to use this thread as a form of person log for a bit so any future Linux SS13/BYOND gamers can look here to hopefully help them.

I'm not a very talented person and I should not be looked to as a source for solid information, but I am eager to play SS13 and dedicating myself to getting it running and hopefully helping another lost spaceman out there.

Figured out that enabling Terminal in Lutris was a good idea, lets me see errors and what not but I can't see what the logs were like before breaking it. Nothing to compare current logs of why it's not working to when it was without IE8 and chat. I'm not smart enough to diagnose it without comparing.

Will keep making posts here if I have any new info, good or bad. Wish me good luck spacemen.
So... somehow after a few Fedora updates and restarts, it seems to work again, i have no idea where the issue was and i don't think i want to investigate it...

One thing that may or may not be related:
dnf update wants to install packages named: "wine-dxvk-..."
Afaik it is something like direct3d running under Vulkan. Anyway it made my version of Skyrim unplayable thru Wine therefore i am not sure if it hasn't caused byond too to not work.
Right, this might be helpful later when I actually bother to try make it work. Did you manage to get Spacestation 13 itself working or just Byond?
Yes, there was never an issue with SS13 itself, only with Byond.

Login to reply.