Filters with color matrices did not animate them correctly.
BYOND Version:513
Operating System:Windows 10 Home
Web Browser:Chrome 88.0.4324.182
Applies to:Dream Seeker
Status: Resolved (514.1549)

This issue has been resolved.
Descriptive Problem Summary:
In an earlier byond version, I used animated color filters to smoothly transition from color to color. When I try this now it only moves to the next color after the animation step ends, transitioning instantly.

Numbered Steps to Reproduce Problem:
1.Make a multistep animation on a color filter
2.Watch it not transition smoothly from color to color

Expected Results:
The colors should transition smoothly from the first to the second color

Actual Results:
The colors only transition after the step ends, doing so instantly

Does the problem occur:
Every time? Or how often? Yes
In other games? Yes
In other user accounts? Yes
On other computers? Yes

When does the problem NOT occur?

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.)
It worked before, but I'm not sure what version at all anymore as it was some time back.

This needs a test case. Also it should be tested against 514.1548 to see if it's still relevant.
I'll get you one after I finish work.

I used the your first world project from Dantom to quickly make a test case, on /turf/floor/New() I run a color filter which should slowly move through the color spectrum, but as I mention in my bug report, this does not happen, it only jumps to intermediate points. For reference, at some point this used to work, we used it like this in SS13.
That site is not working for me. I know it used to in the past but they did something to it and now it's straight-up broken. Can you upload somewhere else?
Yeah, that's a no-go as well. Isn't there a more common site you can use like Dropbox or Google Drive, or even post it in Discord?
In response to Lummox JR
I see the bug but I'm not seeing it in 513 as reported, only in a beta. Can you confirm which version actually shows the bug?
I think I tried it on 513.1534 first, and now I tried it on 513.1542 just now and it still happens
Lummox JR resolved issue with message:
Filters with color matrices did not animate them correctly.
Well now this is weird. When I tested it was in an older 513 build (513.1539), and that actually worked fine. But 513.1542 does indeed show the bug. So, my mistake there. Apparently this broke in 513.1541 when fixing a related bug.
Cool, thanks for fixing it! Sorry for the messy bug report, I'll try making it a bit neater next time.