ID:2789701
 
(See the best response by Kaiochao.)
Hey guys whenever I try to leave Byond running over night or while im doing things away from my PC it always crashes after a few minutes which is really irritating if you let it idle train on your games.

If i'm at my system its perfectly fine, but for some reason if I'm away from my actual PC for usually around 30 minutes the error happens.

Things ive tried to do to fix this are:

- Reinstall Byond (done this 3 times now)
- Change to Wired internet connection
- Allow everything including Dreamseeker, Dream Daemon and Dream Maker in firewall
- Run as admin

Any more help on the matter would be greatly appreciated.

EDIT: Testing out changing compatibility settings to windows 7, although i havent really got hopes that this fixes it seeing as ive tried XP and windows 8 and not had any luck.
How does it crash? Are you getting any error messages?

Are you joining a game that has a feature to automatically kick idle players?
In response to Kaiochao
Kaiochao wrote:
How does it crash? Are you getting any error messages?

Are you joining a game that has a feature to automatically kick idle players?

No error messages are given, it just loses connection constantly after a while (Usually like 20 minutes)and forces me to close and re-open byond.

As for the feature to auto kick idle members, I assume there isn't a feature for the game as there are pretty much multiple players who leave their game character logged in all day every day idle training.

Theres just me and a select few other players on there who can't seem to get the game to let them idle it while theyre not at the game.
In response to Katsurune
Best response
One possibility: check your router settings for a group/network key rotation interval, and disable it. Routers often have it set to hourly, so you'll disconnect every hour. Look up what it's for, since it's related to security, but it's probably not important.
In response to Kaiochao
Kaiochao wrote:
One possibility: check your router settings for a group/network key rotation interval, and disable it. Routers often have it set to hourly, so you'll disconnect every hour. Look up what it's for, since it's related to security, but it's probably not important.

I'll have a look if i can find these settings, though im not entirely where they would be in my Virgin Media hub settings.
Update: Given up looking for group/network key rotation interval setting as i couldn't find it.

Also starting to give up on hoping i can fix this issue tbh, Reformated my system and also force closed the pager because i read somewhere that the pager feed can cause issues just incase that was the problem and its STILL giving me issues.
This probably has something to do with power saving, like display turning off, going into sleep mode, network card turning off, etc... I would look into those first and foremost since it doesn't happen while you are at the computer. IMO, a lease on the router doesn't make much sense to investigate as a source of this issue as this would occur at lease expiration or before whether or not you are at the computer.

Login to reply.