Hello, before posting this I already did my rounds to look for a solution and many came up, even some was resolved. But after following them and attempting them (many of them were years old, nothing recent) I find myself having the same issue.

No matter how I open up Dream Maker, or no matter how many times I reinstall, or try to find the txt file to delete a certain code (I didn't find the file in the folder directory that it was told it would be in) nothing worked.

The program seems to be running, but it refuses to show on my screen.

Thank you in advance.
Open Task Manager and make sure they're not unresponsive in the background for some reason; if so close them and try again.

Alternatively: restarting your device should remedy the issue in *most* cases.

Never happened to me with DM but my old PC used to stutter when opening apps and it would sometimes cause similar issues with the programs i was trying to open.
In response to Kumorii
Yeah, it's not running as a background process. It seems the windows is just opening outside of my screen. Kind of weird. Its a common issue I seen people have years ago but no one recent is bringing it up. The solutions they had for people those years ago aren't working now.
Does the Dream Maker icon appear on the task bar in your list of opened windows? If so, you can focus on it (left click the Dream Maker icon once on the task bar) and hold down the Windows key and use the arrow keys to re-align it onto your screen if it's gotten dragged off screen.
In response to Spevacus
I'm not sure if it's opening properly. Whatever file I click open it opens it as 'Untitled'. I've tried reinstalling it many times and holding down the windows key with the arrows, but neither works.

I will say now though I am using Windows 11. Not sure if that changes anything.
In response to WoeKage
The app also does show in my taskbar to add.
In response to WoeKage
Your hunch feels right. If it's opening as "Untitled" it certainly sounds like it's not opening correctly. Something to check might be your Windows Event Viewer to see if it's half-crashing on startup.

You're not installing BYOND to a OneDrive folder or anything like that are ya? Further, is there any weird antivirus software installed that might be messing with us?
To clarify the OneDrive thing, it's really a problem when the Documents folder is in OneDrive. BYOND puts its user data folder in Documents\BYOND by default, but if that's in OneDrive it seems to mess crap up. I don't expect that to impact Dream Maker, though.