So I have been using the beta version of byond for a while now but with the resent bug that happened in a game I play, I have had to use the stable version to fix it. When I tried to download the stable version, it simply wouldn't. Like it would start the download and reach the end but it would not install. I have checked the firewall and saw nothing that would affect the installation. Seeing as that failed, I uninstalled the beta version and downloaded the stable version. Everything went well and started to open it and it won't open. It starts up to open like normal but the main page/menu or whatever will not open.

Am I doing something wrong?
After some more fiddling I figured out how to see the main screen except now everything on it is unresponsive. No matter what I click on it, nothing happens or changes.

Is anyone even seeing this
Not certain if same bug, but ive tried reinstalling, downloading latest version, beta version ect

i can download it just fine but when i click the byond icon
it does something, but it doesnt open the screen, it doesnt appear on the toolbar, in the taskmanager it shows byond is running but i have no interface to use

here was solution, it was OneDrive
Thanks for the help @Niko562. It finally worked after trying your solution.