Uh, I have no idea what is going on, but whenever I open BYOND, I get the following error: byondbug.jpg

I've tried rebooting, as well as uninstalling BYOND and reinstalling it. Nothing seems to make BYOND work again! If anyone knows anything about this, please let me know, because in the meantime I can't use BYOND any more.
Uh.... I'm bumping this because I really need help >_>
Without BYOND, I can't play games, make games, or even properly use my recently renewed BYOND membership...
It would help to know a little more info. Which version of BYOND? What's your operating system? Did you recently change, install or uninstall anything on your computer? Have you tried virus scanning? Probably not the problem, but it couldn't hurt.
In response to Xooxer
I have both versions of BYOND (3.5 and the newest 4.0) installed on my computer. Until recently, they both worked fine, but since I installed the latest update, neither work. I've tried uninstalling both, and even manually deleting the files. Nothing. Virus scan shows nothing, unfortunately. My first thought WAS virus, but evidently it's not.

Anyway, I'm running Windows XP, if that helps at all. I should have mentioned that before, I guess I just didn't think it mattered.
Sorry to double post, but I just managed to fix the issue on my own. I uninstalled both versions again, then went through the BYOND application data and deleted things like the cache folder and some of the stuff in the cfg file manually. Then, once I reinstalled BYOND, it worked fine. I still don't know WHY this all happened, but I'm glad it's finally working again.
Sometimes the cache can mess up BYOND. It might have been a corrupt cache file, or perhaps the cfg was messed with by the new installation. Glad you figured it out.