Keywords: copy, file, game, icon, lag, map, new, old, paste

Problem description:

well, i found out that when i added my new map, that is what caused my game to lag, i went to my documents and copied the map file which was saved in another folder, and then pasted it to where my game was, refresh dream maker, then checked the new map, and unchecked the old one, and when i compile i get no errors, but now it causes lag, so is there any type of way im suppose to add the map? please help me
I can't think of any reason why your map would cause errors or lag, unless you actually replaced your map with one from a backup folder.

If your map has somehow changed, then you need to figure out why the previous would have errors, or why the new one causes lag. Likely causes of this would probably be accidental placement of the same object multiple times, or maybe some poor coding in certain objects or enter procs and such.

These are just theories. More info would really help narrow it down. There has to be some sort of difference between the two, or they wouldn't act differently.
well, it cannot be any enter procs, b/c same turfs used, also checked for multiple stacking and there is none, also nothing in code since old map did not lag, all i did was send him my source for him the edit map, he edited 2/10 maps for me, then sent me just the map file back, i then saved in my game folder show it shows up in source, then i checked the new map file and unchecked the old one, compiled, run, it doesnt lag, but the movement of the character is choppy, its hard to explain, if i move one tile up or down or whatever, i should see full walk motion, but now it doesnt it will only move character, so it is very choppy. also no i did not replace my map with a backup one from backup folder.
Huh, that's odd. It sounds like your project may have pixel movement activated unintentionally, or maybe your glide setting somehow got changed.

If, at any time, either of you pasted everything from an old source into a new one that could of lead to the pixel movement being active because of the new code included in any projects created in DM now. Otherwise, not sure, but I suggest checking to make sure there is no step_size code in your source, and then also check your animate_movement var to make sure it hasn't been set somewhere in an incorrect manner.

If you're unfamiliar with it, look it up with F1 in the help on DM. Just mentioning that just incase. Not sure if these are your issues, but it's the only thing I can think of that would do this that can be set accidentally; though it is extremely rare.
see thats the thing, i thought it could be something strange going on but i decided get my backup source out, and i loaded the new map on, then i just copy/pasted the 2/10 maps ontop of the old one, get it? so map file never changed, and nothing was stacked, and i still got same result, and im sure b/c ive tested it multiple times
well, never solved the problem....
Hm. I'm running low on ideas, but have you tried using #define debug to turn on debug, and then using profiling to check for any errors or problems there? Also, did you update your BYOND version recently? Backwards compatibility issues are rare, but it is possible that some changes may have made previous bugs in your code easier to notice.