ID:118839
 
Resolved
Saved skin parameters were loaded even when they had no corresponding entry in their control's saved-params value.
BYOND Version:489
Operating System:Windows 7 Pro 64-bit
Web Browser:Chrome 14.0.835.163
Applies to:Dream Seeker
Status: Resolved (490)

This issue has been resolved.
Descriptive Problem Summary:
Enabling control_freak so that skins can't be edited doesn't delete older saved skins, so when players login they can say "no" to updating the skin and keep their changes. Also, they can just go to the skins folder and edit the skin from there.

Numbered Steps to Reproduce Problem:
1. Edit a skin while control_freak is not enabled.
2. Disable the ability to edit skins.
3. Login and say "no" to updating skin or go and edit skin directly from skins folder.

Expected Results:
Default skin used no matter what.

Actual Results:
Not the expected results.

Does the problem occur:
Every time? Or how often? Every time.
In other games? Yes.
In other user accounts? Yes.
On other computers? Yes.

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit http://www.byond.com/download/build to download old versions for testing.)
Not sure.

Workarounds:
None.

I was unable to verify this. The question of whether to update the skin should never even come up if control_freak has skin editing turned off when the user first connects. If you're trying to change that after they first connect, right now I can't think of a way to make it work, since the skin is loaded when the user connects.

In my testing, I set a bogus hub path for my test project, and edited that skin. I tested out the edit to make sure it worked as expected. I then changed control_freak to CONTROL_FREAK_SKIN at compile-time and recompiled. When I started the world again, my edited skin was unavailable. I tried CONTROL_FREAK_ALL with the same result. Resetting CONTROL_FREAK to normal let my local edit work again.
Lummox JR wrote:
I was unable to verify this. The question of whether to update the skin should never even come up if control_freak has skin editing turned off when the user first connects. If you're trying to change that after they first connect, right now I can't think of a way to make it work, since the skin is loaded when the user connects.
In my testing, I set a bogus hub path for my test project, and edited that skin. I tested out the edit to make sure it worked as expected. I then changed control_freak to CONTROL_FREAK_SKIN at compile-time and recompiled. When I started the world again, my edited skin was unavailable. I tried CONTROL_FREAK_ALL with the same result. Resetting CONTROL_FREAK to normal let my local edit work again.

I'm not 100% sure on many of the issues since a lot of it is relaying what players have told me, but I do know for sure that I can go in and change things in the saved.txt file and they will make those changes, even with editing skins disabled.
The saved param issue actually is substantive, so I'm changing this report to be about that and closing it with a patch.

From now on, parameters in saved.txt will be ignored if they are not in the skin control's saved-params value.