ID:107813
 
BYOND Version:479
Operating System:Windows XP Pro
Web Browser:Firefox 3.6.13
Applies to:Dream Maker
Status: Unverified

Thus far we've been unable to verify or reproduce this bug. Or, it has been observed but it cannot be triggered with a reliable test case. You can help us out by editing your report or adding a comment with more information.
Descriptive Problem Summary:
Well, when one has an a large atom in the Map editor and you scroll one tile past it it disappears. Not much to say but it can get a little annoying.

Numbered Steps to Reproduce Problem:
1. Open the map editor
2. Put an atom with a large icon on the map.
3. Scroll in any direction one tile past where th actual atom is.
4. *Poof*

Code Snippet (if applicable) to Reproduce Problem:
N/A

Expected Results:
It will still show the object.

Actual Results:
This...

Does the problem occur:
Every time? Or how often? Yes
In other games? N/A
In other user accounts? N/A
On other computers? Not Sure.

When does the problem NOT occur?
When the atom isn't huge?

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit http://www.byond.com/download/build to download old versions for testing.)

The problem didn't occur in older versions but not really sure when it started.

Workarounds:
Not sure if there are any.
The map editor is supposed to be able to handle these cases. Can you make a simple demo of this and send it to me at LummoxJR@aol.com? It'll be easier to fix this (once we're back on software bugs) if I have something to look at. I can probably build a test case for this but it'll help if we're on the same page.
After running a few tests I saw that this only happened on one source and I'm not really sure why...
Okay. If you want to send me that source and point out which map (and which object type, icon, etc.) has the issue, I can take a look at it when the time comes. Or if you can narrow down the cause more specifically, just post a followup here.
Confirmed in 479.

I'm testing it with the Decadence maps, which there are only three of, and the bug only seems to happen on the second z level. There's some funky stuff going on.

If I place the exact same disappearing objects anywhere including the same z level they wont vanish. I can line them up and have the older ones vanish while the newer ones display just fine, despite being the exact same object.