ID:85826
 
Resolved
Fixed in 459
BYOND Version:457
Operating System:Linux
Web Browser:Firefox 3.5.5
Status: Resolved (459)

This issue has been resolved.
Duplicates:id:85564
Descriptive Problem Summary:
I updated FFO with world/map_format = TILED_ICON_MAP
No other changes were made to the game.
I hadn't tested it using any of the recent betas;
it had been running on 454 up until last night.
{edit: the game was compiled using 458 if that makes a difference}
I haven't had time to test this extensively, but here are my results after 3 attempts to get it up and running on 457:

Numbered Steps to Reproduce Problem:
attempt to load FFO using standard protocol

Results:
DD crashes after about 2-3 minutes of loading FFO.
no bugs listed in error log text file
nohup.out reads:
Tue Nov 17 15:16:58 2009
Auto-safety mode: safe (working directory access).
World opened on network port 2442.
Welcome BYOND! (4.0 Public Version 457.1049)
The BYOND hub reports that port 2442 is reachable.
BUG: Crashing due to an illegal operation!


One thing of note:
The first time I tried to run FFO, nohup.out contained an extensive crash report that seemed to indicate a problem with libbyond.so and/or libext.so. I had forgotten to copy over the old libs, so I reinstalled BYOND again just to make sure everything was in order. Specifically:

 
download 457.1049_byond_linux.zip to home directory
unzip 457.1049_byond_linux.zip
cd byond
sudo make install
sudo cp bin/lib/* /usr/lib/


Since the reinstall, nohup.out only contains the relevant line "BUG: Crashing due to an illegal operation!" with no mention of the byond libs. Rebooting the computer hasn't helped either.

I'm not sure what else I could test at this point that would be of use to you, but please let me know what other info you might need.
Does this game work in Windows, or is this a Linux-only issue?

Without core files to trace anything back I'll probably need to test this out myself. Is the game available for download on the hub (if so at which hub entry), or if not would you be able to send me a copy of at least the hosting files, preferably also the source, at LummoxJR@aol.com?
From your trace, I have a rough idea where this is happening. However, because the debug data you provided was built on a different version of BYOND than the one we have here, I can't isolate it completely. The easiest thing would be if you could provide a (temporary) copy of your .dmb/rsc so that I could just dump the core here. Or I could provide you with a debug build to test.

That said, we'll look over the preliminary info and see if there's anything obvious there.
Thanks for the files. I believe I have fixed this. I just want to confer with Lummox JR as this is in some new code of his.