ID:132250
 
So I couldn't help but realize that pixel movement came out at BYOND 490 when it would have been something really awesome to introduce into a new integer version of BYOND. This leads me to believe they have something even better in store for 5.0. It looms near, I can see it in late 2011, early 2012. Is the flash client gonna be what's going to throw BYOND integer++?

I'm very interested in this Flash thing that seems to be going on. What's the news about it so far? Will it support statpanels? Skins? Is it just maps and HUDs? What's up bro?
Ganing wrote:
I'm very interested in this Flash thing that seems to be going on. What's the news about it so far? Will it support statpanels? Skins? Is it just maps and HUDs? What's up bro?

This. I can't wait to jump into this and see what crazy things I can cook up and embed into a website.

Taking BYOND essentially multiplatform in terms of playing games is concerned would very much be on the same level as the interface support of 4.0, IMO.
Ganing wrote:
Will it support statpanels? Skins? Is it just maps and HUDs?

Dream Seeker uses WINAPI, while Flash doesn't support that. Therefore I doubt they'll implement that.
http://www.byond.com/members/ BYOND?command=view_post&post=106285

http://www.byond.com/members/ BYOND?command=view_post&post=110595

They're going for ~3.5 compatibility, as far as interfaces are concerned. Assumedly, they'll get some of the newer features in too (big icons, pixel movement, ect). Based on my own knowledge of Flash's limitations, the following probably also won't be supported: multiple windows (duh), embedded browsers, and right-clicking (including verb popup menus, unless they try a hacky solution).

It's generally been suggested (not by the staff, but by other community members) that if you're going to make a game for the Flash client to come, restrict yourself to the map (and HUD). As you can see in that first post, it looks like they have the input/output controls working, too. Anyways, I would assume nothing is set in stone.
Just for reference, just because it's 490 doesn't mean we're close to "5.0". It just follows a general version numbering system, we could end up seeing 4.99.99 and then 4.100.1 instead of it going to 5.0.1.

This was a common issue before the 4.0 release, people always expected 4.0 to be right around the corner because the version number was "close" to 4.0, when in fact it was nowhere near 4.0.
We're doing our best to get as much 4.0 compatibility as possible. Certain things (particularly the embedded browser) won't work, but it looks like Flex is pretty well fleshed out to handle most of the stuff we have. And if we move to an HTML5 port (whenever that is standardized), I think we could have even more support.

We'll release something before the end of the year.
In response to Tom (#5)
Exciting news =). I've just come to love working with interfaces, so I'm glad we won't lose everything.
In response to Tom (#5)
I hope this includes Flex-based developer tools so I can finally write BYOND games again.
In response to Ryan P (#7)
I am hoping they make it much easier to have side scrollers in 5.0 somehow. as is, its a fiendish headache to make such games presently.
In response to Developous (#8)
Developous wrote:
I am hoping they make it much easier to have side scrollers in 5.0 somehow. as is, its a fiendish headache to make such games presently.

It's been quite possible for a while now. Some of these hub entries are over a year old:

http://www.byond.com/games/SuperAntx/PascalsChallenge (slightly over one year old)
http://www.byond.com/games/DivineTraveller/DoomedDreams (~13 months old)
http://www.byond.com/developer/Forum_account/Sidescroller (~11 months old, but existed in other hub entries before that)
http://www.byond.com/games/Forum_account/AMinerAdventure (~14 months old)

BYOND doesn't need to change at all to support these kinds of games, they already work fine. If you have any questions about making a sidescroller, try posting on my forum.