ID:85643
 
Not a bug
BYOND Version:448
Operating System:Windows XP Home
Web Browser:Firefox 3.6
Status: Not a bug

This is not a bug. It may be an incorrect use of syntax or a limitation in the software. For further discussion on the matter, please consult the BYOND Developer forums.
Descriptive Problem Summary:
When map_format is set to TOPDOWN_VIEW, the default, and you attempt to paste a large background image that is in .dmi format (the dimensions of the one i used was a 888x230 image)

What ends up happening in the Map Editor looks something like this...

Photobucket

Wierd. Now place a second tile right next to it, and all of a sudden both tiles are enlarged.

Okay, so how does it look ingame?

IT CREATES A PARALLAX BACKGROUND

Photobucket

That is, a background that completely ignores scrolling. Where you are on the map, you see that background. It doesn't scroll at all.

While some players would LIKE Paralax backgrounds in BYOND, and this seems to be a method of doing it, the "feature or bug" is forced upon you and you cannot avoid it even if that isn't your goal.

To make things easier for you to track this down, I have compiled a demo.

You can download that demo here

(note to self: my project has to be halted until this glitch is fixed X_X. Which, from the looks of things, a fix will be pretty complicated)

Numbered Steps to Reproduce Problem:
1.) Take large image
2.) put it into .dmi and let it caluclate it's dimensions
3.) place as a /turf in the map editor, it seems to shrink to 32x32, even if you use Fill or Add.

Expected Results: a dynamic background that stays in one location without scrolling with you.

Actual Results: a static background that acts as paralax and scrolls with you. Also known as Parallax.

Does the problem occur:
Every time? Or how often? Every time when TOPDOWN_VIEW is on
In other games? Not sure
In other user accounts? Not sure
On other computers? Not sure

When does the problem NOT occur?
When map_format is TILED_ICON_MAP

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit http://www.byond.com/download/build to download old versions for testing.)

Workarounds:
Set map_format to TILED_ICON_MAP, which also disables the new big icon functionality )which is awesome by the way, good work on that!)
Your information in this report is conflicting. You say the problem happens when TILED_ICON_MAP is on, but doesn't happen when it's on. Which is it?

It looks like at worst there's a bug in the map editor. I can't really tell what you're talking about as far as the behavior in DS, so you'll really need to clarify this a lot further.
Lummox JR wrote:
Your information in this report is conflicting. You say the problem happens when TILED_ICON_MAP is on, but doesn't happen when it's on. Which is it?

I supplied a source code in the post. Sorry, I meant to say this bug only occurs when TOPDOWN_VIEW is enabled, and is fixed when the map_format is TILED_ICON_MAP, but in return, you can't use the new big icon system.
I was unable to reproduce your issue in the map editor.

As for the in-game issue, I can say confidently there is no bug there. What I saw was a result of your map having placed sub-tiles, which would have happened if you edited the map while in TILED_ICON_MAP mode. Those large images were broken down into lots of individual pieces like "0,0" and "1,0", etc. BYOND fell back on the default state since those did not exist in regular TOPDOWN_MAP mode. You were seeing the background fail to move because at each place there was one of those "tile pieces" to be drawn on the map.
Deleted map; created an all new map in topdown_mode; bug still persists.

If you get a chance, see if its possible to place one of the large backgrounds at the edge of the screen

Oh, and if it helps, i don't have a really good graphics card. It's the one that ships with the computer, though i have a good driver

If it helps, the big 'turf' file isn't rendering at all unless it's being overlapped by another big turf.
I also tried creating a new map while in TOPDOWN_MAP mode, so there has to be more to it than just that. Maybe you could expand on the numbered steps, since more detail could show what's different between what we're both doing.
Here is video evidence of the bug

If I did something wrong, tell me.

http://www.youtube.com/watch?v=Qog9OADT5Ck
The map editor bug I've resolved in a separate report. The issues you're having with gameplay are not bugs.

While it appears you did correct the problem of the x,y states showing up on your map, the background is disappearing because per the reference, BYOND only allows for up to 3 extra tiles' worth of space to show big icons, lest the server-client communication get too overwhelming. So the disappearing background is in fact normal.