Problem description:

So i have been setting up my start screens and i have come across something that i find rather odd im not sure if its related to my code or not since it only happens every now and then but my maptext will not show up at all until i have fully loaded a character.

i use the hud groups library by FA and the maptext lib by fisher now when a player logs in they are set to a temporary mob and greeted with a title screen from there they go into the load screen and then character creation screen.

the maptext will not be in some launches where as in others its there fine, i can still make a character without any hassle since all the other things are displayed just without text.. ive only ever seen it happen in a quick launch and never when i do a host, i can open and close and relaunch plenty of times and get the same result.. maptext 100% of the time, quick run maybe 50-65% of the time the text shows up.

inside the load system when a mob is getting loaded a proc is ran to make ready the huds (FA HUD Lib) i have found if i stick a spawn(2) there it seems to work fine all the time in a quick run with no change in hosting.

Any thoughts on why this is happening?
Haha, May 2nd..

Anyways put some more info and stuff in there
I'm having a similar problem. The maptext shows up on the first login but if you reconnect, the maptext wont show up again until you fully close the game.
I've found that if you don't implicitly set the font and font color and font size for every single maptext value, you'll end up with some wonky default styles that change from launch to launch.
Each of my maptexts have set height, width, color, size, and placement. But nothing shows up the second time. It's weird because if I reconnect, it won't show up, but if I logout and log back in, it'll show up.
In response to RebornxDart
If you're still getting that problem with maptext upon reboot, you should either get this proper attention as a new topic in the bug report section, or maybe add onto/bump This thread with your information if the problem still persists.

I'm not sure if it's just that you'll need to update byond to the later versions, wherein i'd gather the problem has been fixed (due to Tom's response on that thread) or if the fix just hasn't completely worked -assuming that you do still see this problem/behaviour when rebooting- as was thought.

Hmm... it might be that it just isn't in the latest build yet. Either way it's probably fine to ask about it/follow up on that thread if you're still needing a solution.