Hello,My byond isn't opening ANY games i try,i tried reinstalling it,getting another version,checking if my antiviruses was blocking it but none of those worked,last month it was working perfectly but then suddenly it decided to stop working.

Can you guys help me?

Which byond version are you running? That would be step 1. The stable release, or the beta? Are you fully updated?
i tried all available versions like the beta and the stable,also im running this on a windows 10 home 64bit.
I can't say it's the problem for sure but when I used Windows 10, I had alot of issues, not just with Byond, but with everything. That's why I went back to Windows 7... And cuz Windows 10 is ugly as sin and it made me wanna smash my PC everytime I looked at it.

If you're not able to open any games at all, then I am not really sure what to tell ya. I would suggest uninstalling and reinstalling but you said you already did that. I really don't know. Sorry.
Actually i cant open any byond games at all,and a month ago it was working perfectly i was playing space station 13.
Can you describe what you mean exactly by "not working"? What happens exactly when you go into the pager and then try to load a game?

Also, is it possible you have antivirus or security software interfering?
Same thing is happening to me for certain game servers Lummox. I'll write my info down for you to check.

-Windows 10 64-bit
-Happens on both current stable and beta version.
-I barely have any programs besides BYOND, discord and Unity on my computer

What specifically happens:

-The first time I start up the pager, it looks like I'm getting into the game (waiting for the ad etc). When the timer hits zero, it looks like I'm about to get it, but it immediately says "Connection Closed"
-Anytime after that, without restarting the pager, it looks like it is starting up, but immediately closes the window 5 seconds after startup. No ads by the way.

I've spoken to the server owner of a specific game's server this happens on and it is not on their end (No errors in Dream Daemon). I also can access another server of the same game.
In response to CipherWing
You can't say it's the same thing when none of us know what the OP's actual issue is, since we have yet to get a description of the problem.

The "Connection closed" message you got means you've disconnected from the game. This is likely to be a problem along the route between you and the server, in which your connection is sporadic enough that TCP/IP can't maintain a connection.
i already checked my antiviruses...... oh wait,no one knows how to fix it? Nevermind then
In response to Igoral
Igoral wrote:
i already checked my antiviruses...... oh wait,no one knows how to fix it? Nevermind then

So far you haven't yet explained exactly what you mean by "not working". Nobody can help you without more detailed information.
What i mean by not working is nothing happening when i click join.
What does your task manager say? Does dreamseeker.exe appear in the process list? Is it showing any CPU usage if so, or does it appear to get "stuck"?

This still strongly smells of antivirus causing interference. What did you check exactly to ensure it wasn't an issue, and also what antivirus are you using?
i checked my avast,not the windows antivirus itself but i think it gets deactivated when avast is downloaded.And NOTHING absolutely nothing happens when i click join and by nothing i mean N O T H I N G.
Avast could be a big part of the problem. It's been known to have false positives with BYOND in the past and honestly it hasn't been very good for a couple of years now.
But it was working perfectly a month ago,why just now avast would do that,and i already deactivated avast and tried playing but still the same.
The big question is, what changed a month ago?

Deactivated antivirus can still try to "protect" you, try to remove the Avast completely.

Maybe it's not antivirus problem, there were similar reports for 512:
and some reddit threads
same here I only played a game once and went to Walmart and when I came back it didn't work anymore
Okay to give a better overview of this, I *HOPE*
It has been reported elsewhere on discord too and it had happened to me once, but I am unsure if it was due to my own code or BYOND. (But that still means it happens)

What happens is when you start the game, the dreamseeker.exe process begins, starts taking up some CPU, but the game screen never opens. Opening a new game doesn't work either.

Workaround is to open task manager, kill the process and reboot, then it works.
Page: 1 2