(See the best response by Higoten.)
Descriptive Problem Summary:
Cannot open BYOND, gets stuck at 100% forever. I have looked at numerous other pages but none have seemed to be able to fix this issue (or have, but the fix isnt working/ unable to do)
some say to install internet explorer but that got discontinued
some say to delete some things in the cfg but half of what they're talking about doesnt even seem to be there, and deleting all doesnt help
reinstalling doesnt help
allowing it through literally every antivirus option doesnt help (even uninstalled kaspersky, then reinstalled this, still no luck)
also it seems to instantly get to 100%, not sure if its because it just naturally would load that fast (SSD) or if thats whats broken.
also i have the latest versions of Edge (109.0.1518.70 ) and Opera GX (108) installed, not sure if i shouldve listed those in the browser area.
Numbered Steps to Reproduce Problem:
1. open BYOND
2. suffer
Code Snippet (if applicable) to Reproduce Problem:

Expected Results:
does anything other than say 100% saying "loading live games from HUB" for eternity
Actual Results:
stuck at 100% saying "loading live games from HUB" for eternity
Does the problem occur:
Every time? Or how often?
every time
In other games?
cant even get to hub
In other user accounts?
read above
On other computers?
dont have any
When does the problem NOT occur?
Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.)
When i had windows 10 like a year or two ago

This was supposed to be in bug reports, absolutely no clue how it ended up in general help.
It was moved here by a moderator because what you're posting about seems to be a technical issue on your side and not necessarily the work of a bug on BYOND's side.

It sounds like you were using Windows 11. BYOND currently relies upon Internet Explorer, so I would try downloading IE. You don't need to use it, just have it installed.
In response to Spevacus
That is not possible. As i stated it got disctontinued. any attempt to install it will bring you to microsoft edge. I have the actual installer for it, and every time i run it it says that edge is better yada yada yada
if it has to do with a requirement being unavailable to new/returning users, doesnt that count as a bug? at the very least its not only my side
In response to Spevacus
Its not just my side, internet explorerer was completely discontinued and it is not possible to get it again, from any source, on windows 11. any attempt will bring you to edge.
can this be moved back to bugs?? I feel it might actually get someone to respond if it was there...
Windows 11 isn't missing the components required to utilize MSHTML (which is what BYOND is using), it's unlikely the issue here. It's not considered a bug because it's something specific to your system, I've been using BYOND on a Windows 11 machine without issue for months now.
In response to James
internet explorer is required to run this program as has been stated

internet explorer cannot be obtained if you do not already have it installed

I am not sure what to tell you. This is literally how it is, any new users will have this issue if they dont already have explorer. Not just me. Do you want a screenshot of the window that pops up? i mean like, im not lying here, you literally cant install it.

Im trying to be civil and respectful but there is only so many ways i can say the same thing.

In the end, having it being reliant on a discontinued app isnt good regardless. Ive seen people have this issue exactly, and each post was solved by installing explorer.
Hello StardustGenesis,

If you are using the Japanese locale, that has been known to cause issues with BYOND.

Otherwise, here are some steps to follow to help eliminate the possibility of corrupted configuration files being at play.

1) Do a full Windows shutdown from the start menu by selecting the power icon, then hold Shift and click Shut Down. Then restart your computer. This will bypass any fastboot settings common on newer PCs and help eliminate the possibility of a rouge background process.

2) Locate the BYOND user directory folder. Normally this is located in users/[user]/Documents/BYOND, but it is possible to be in another location. This can be confused with the BYOND folder defaultly located in program Files(x86)/BYOND. If the BYOND folder contains a folder named "bin", then you are in the wrong one. Normally this folder can be accessed via the pager, but that isnít an option in this case.

3) Once you have located the BYOND user directory folder, rename the folder to BYOND.old

4) Attempt to launch the BYOND pager. New configurations files should be generated, and may resolve the issue.
In response to Higoten
Unfortunately I have tried all this.
just for fun, I tried it again.
no luck. Same issue.

as a note, I have already spent a good amount of time going through forums and posts trying to fix this, I don't think any simple tricks will fix it. I have completely removed every last trace of it, as well as tried multiple different versions, as well as antivirus' with nothing having any effect on it. My OS is a completely normal, up-to-date version.

I've even for the heck of it tried it in a sandbox and a vm, neither showing any improvement.
In response to StardustGenesis
Thanks for following those steps, I wanted to be sure we were on as clean a slate as possible, just in case.

Go ahead and try to launch the BYOND pager again, this time when it becomes stuck, click on the splash to ensure the program has focus and press CTRL+L. This should launch the login prompt. Attempt to login with your username and password. If the login is unable to verify, then it suggests that something on your PC is interfering with BYOND.
In response to Higoten
While I am now logged in, nothing else has changed. Also I'm only assuming im logged in, it has my info saved and when i click log in the window just closes back to the loading hub.
edit: okay it does recognize a wrong password, so assuming im logged in.
In response to StardustGenesis
Best response
The hub is showing that you are online, so you did connect successfully, suggesting that the pager can communicate with the hub.

If you have a specific game that you want to join, you should now be able to using your login, by following these steps (these steps shouldn't resolve the pager issue, but may sidestep it if you're primarily interested in connecting to a game)

1) Find the server you want to join using the BYOND website and right click on the "Play Now" image and select "copy link location".
2) Locate dreamseeker.exe and run it. It is located in Program Files(x86)/BYOND/bin by default. It will prompt you for an address, paste the link location you copied in step 1, and click OK. You should be connected to the server using your BYOND key.

As for the pager issue, try restoring the default settings in the Internet Options dialogue:

1) Search for Internet Options in the windows search bar.
2) Go to the Security tab and select "Restore all zones to default level"
3) Go to the Advanced tab and select "Restore advanced settings"
4) Click apply and OK, then test to see if the pager issue has been resolved.
Both of these work, thank you very much! My windows security setting was set higher than normal, I thought allowing it through the AV and security whitelist would bypass that but I guess not. Should i delete this post now?
Glad to hear the issue is resolved! If you would, please leave your post around so that others who may have similar issues can use this advice for reference.