BYOND Version:515.1599
Operating System:Windows 10 Home 64-bit
Web Browser:Firefox 109.0
Applies to:Dream Maker
Status: Open

Issue hasn't been assigned a status value.
Descriptive Problem Summary: When using the Move/select tool in the map editor, selecting a turf and using the delete function results in a removal of the selected grid contents that cannot be undone.

Numbered Steps to Reproduce Problem:
1) Download the following test project:
2) Open the map file and select the Move/select tool.
3) Select a purple turf that contains a blue three, ensuring to click on the purple turf, not the blue three.
4) Press delete on the keyboard, or use Delete from the context menu.
5) Undo the last action (ctrl + z).
6) Observe that the action has not been undone.

Expected Results: For the action to be undone following the steps above.

Actual Results: Nothing appears to happen.

Does the problem occur:
Every time? Or how often? Every time following the steps above. Otherwise, the issue can be inconsistent.

When does the problem NOT occur? Unknown.

Workarounds: Unknown.
I can't reproduce this. I downloaded the test project, opened up the map, clicked the purple turf with a blue 3 but not the blue 3 itself, pressed Del, and then pressed Ctrl+Z. The undo worked as expected.
In response to Lummox JR
Sorry, I neglected to mention in the report that this only occurs in Classic instancing mode.
I switched to classic mode and tried again, but I'm still unable to reproduce the issue.
In response to Lummox JR
Bummer, It is a seemingly inconsistent issue that I had thought I had nailed down steps for. I'm unsure what else would be at play here, but I'll try and recreate it in another way.

For reference, here is a brief video demonstrating the issue with the steps I intended to convey, only using context menus:
Well, if you figure it out please let me know. I won't do a new release till at least tomorrow anyway.
When I can get the issue to occur, the problem appears to be completely visual. Reloading the map reveals that an undo did occur, it just didn't refresh.

Here's a .gif demonstration (right click, open image in new tab if it's not easy to see):

I also found that it happens more often on a fresh version of the linked project as opposed to a copy that I've attempted to perform this issue on multiple times.

Not sure if this helpful, just tossing this out there so you could, potentially, catch the problem. From an outsider's perspective, it just looks like it's sometimes not redrawing.
In response to Spevacus
Thanks for experimenting with the report and offering some insights, given the test project is too unreliable currently. Although I believe that the visual-only suspicion may be a bit of a red herring at this moment.

Following the failed undo, it is likely that the map isnít being saved (because all changes were "undone", the map editor removes the indication that the map needs to be saved, and no save prompt is displayed when the file is closed), resulting in the refreshed map just being the original, unedited map.

This can be confirmed by manually saving the map following a failed undo, then reloading and observing the deleted then "undone" turfs are still missing.
I haven't been able to get this bug to happen reliably, but I was able to rule out a few things I initially thought were related:
1) This isn't related to Classic or Copy instancing mode, as it can occur in both.
2) This isn't likely related to turf underlays/overlays, as it occurs with single solid-tile turfs.
3) This seems to apply more broadly to any selection, as it has unreliably happened with the Select Rectangle Tool involving multiple locations.
After testing with 515.1600, this no longer appears to occur when using the Move/Select tool as specified in the original report. The issue can still occur (unreliably) when using the Select Rectangle Tool with single tile or larger selections.
Given my lack of success replicating this, I'm gonna leave it shelved until there's a more reliable way to reproduce the issue. Right now I still don't have enough to work with unfortunately.

I was hoping that an unrelated fix I threw into 1600 would take care of this, but apparently not. At least it sounds like the issue has been completely narrowed down to marquee selections, which used to be used for turfs.