The whole problem has been mentioned below... This is not exactly a coding issue but a BYOND Hub issue.

Problem description: When I try to download and clean download my owwn game to host, it says download failed... I have a backup of the Game so I tried reuploading but download still fails.
Other games do work and I haven't tried to install another game yet (of my own) because I have been multitasking and I do not have much I can do quickly...
I was a BYOND Member (I think this is Year 4 but I paid 4 seperate years with time in between) and I am a BYOND Member now so I use BYONDs File Hosting but it keep saying BYOND Social download failed.

I tried to remake BYONDSocial and for the hell of it decided to post early to see if it worked... even the new Hub failed to download/install...

I then decided to uninstall and reinstall BYOND...

I now realize (1st of all, my original Hub now says update which got my hopes up) but failed.

It seems like everygame I try to host (I did a couple from other reputable sources) fails...

I have my own BYONDPanel Host so hosting is not the issue... I literally can't download from BYOND.

What would block the download? I thought firewall but there is no error in the firewall (I even turned it off to make sure)

What can I do to understand my problem?

As Lummox JR in the BYONDiscord explained, the links to download your files for your two hub entries point to an HTTPS link which currently does not work.

Making those links instead point to HTTP links should work fine.

It is currently a bug that the "Choose File" workflow available to BYOND members to upload files points to https by default. Lummox JR will fix this in due course.
Thx Guys : )