Hash links didn't work correctly in browser controls.
BYOND Version:515
Operating System:Windows 11 Home
Web Browser:Chrome
Applies to:Dream Seeker
Status: Resolved (515.1641)

This issue has been resolved.
Descriptive Problem Summary:
The href and id attributes in HTML are not working as expected in the current version. Links that should navigate to specific sections of the page using id anchors do not function properly.
Numbered Steps to Reproduce Problem:
1) Create a basic HTML file with id anchors and href links.
2) Attempt to navigate to different sections of the page using the links.
3) Observe that the navigation does not work as intended.

That same code would work in an HTML file outside of BYOND of course.
Code Snippet (if applicable) to Reproduce Problem:
Link can be found here of a test case: 1249240944801353728/ c082ea5721f1ca0293c8e335022424c4b190bde2b1dca98a2a1468aaf42c 6d0d&
Expected Results:
The links work.
Actual Results:

It does not work.
Does the problem occur:
Every time? Or how often? Everytime.
In other games? Every game.
In other user accounts? Every account.
On other computers? Didn't check.

When does the problem NOT occur?
Always occurs.

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.)
It works in previous versions. I went back to 510.1320 and Href worked like a charm.

Lummox JR resolved issue with message:
Hash links didn't work correctly in browser controls.
Just an added note: I tested 516 and this bug didn't exist there with WebView2. So this fix is just a temporary one until 516 is ready.