(See the best response by Lummox JR.)
I recently tried installing BYOND on a new PC I got but after installing it and trying to open BYOND I get error 0xc000007b and am unable to launch it. I saw others have this problem and tried a lot of things.

This one in particular was the most helpful
I tried doing everything stated in the reply of the post and after the second step when trying to open BYOND it did not give error 0xc000007b but instead it gave some errors about missing dll files. I was super happy that SOME progress was there, and for some reason I decided to reinstall BYOND, because maybe that will do something, but after doing that it gave error 0xc000007b again and I became mad and gave up.

Is there any solution, like maybe the same thing from the other post mentioned before but with up-to-date files and all that, or is there something different that I could try. Also the files from the all-in-one runtimes are outdated so I downloaded the remaining C++ files (at least I think I downloaded the correct remaining files) from the microsoft website, maybe that has something to do with it. I also don't really know much about computers so I might ask a lot of dumb questions.
Best response
The download for the Visual C++ runtimes listed on the BYOND Downloads page is the correct one you should be installing. If you've installed that and you're still experiencing problems, then chances are you have corrupt system files.

If you didn't install those runtimes, but installed others that were supposedly newer, go back to the link on the Downloads page and install that one.