When I try to launch the app it gives me this error (0xc000007b). I've seen another post here with the same topic, but it seems to have never been resolved. The error appeared only after I've installed the latest version of BYOND. At first it had a direct reference to a .dll file, but after I reinstalled all of them, it just became a regular 0xc000007b error message.

From what I've collected, this error has something to do with DirectX/VisualC/Video Drivers (I don't know if this makes any sense since I'm not really into all that computer/programming stuff). I've updated my drivers, my DirectX, uninstalled and reinstalled all VisualC redistributables, ran full system diagnostics, yet nothing worked.

I would really appreciate any assistance and will provide any needed information within my capabilities.
When you say you reinstalled Visual C runtimes, did you use the specific link on BYOND's download page for that? Give that a try. You may have installed the wrong files, especially if you went with 64-bit runtimes.
In response to Lummox JR
Yeah, I used that link. It downloaded "VC_redist.x86.exe", I ran it and installed the runtimes.
I think you might need to repair your system files. I can't think of any other explanation for what's going wrong.
In response to Lummox JR
How would I do it? Do I need to reinstall Windows?