ID:2546974
 
hi, i use linux mint 19 and PlayOnLinux, because unlike many other linux users, i'm not an IT specialist, so please go easy on me.

so far i got a wineprefix with the byond installer on its cdrive and installed some of the dependencies listed in other threads here on this forum.

i ran the installer and can even see the serverlists now, but upon joining, dreamseeker.exe crashes.

can someone help me?
Try your luck with this:
https://appdb.winehq.org/ objectManager.php?sClass=version&iId=37797

However, I would seriously recommend going the VM route. It makes this process much easier and produces more stable results.
And if you want to continue using Wine (or if VM is not an option) there is a tutorial on this forum already:
http://www.byond.com/forum/post/2374235
i had problems getting any data onto my VM and all i could find about the problem was some 300 pages pdf about that VM program.

i already followed that second tutorial, installing the prerequisites and creating a wineprefix in PlayOnLinux, installing the listed wintricks stuff.
it refused to install IE8 though, claiming it isn't supported on that OS.
i tried to do so with different OS presets on that wineprefix, going from winXP to win8 and it always refused to install IE8.

so far, i can launch the byond launcher, see the servers, login etc. and then upon joining a server, dreamseeker.exe crashes.

now i'll try some of the things from winehq. thanks for the link
so i installed the required stuff now, but it spew out some errors in the terminal way too fast for me to read and too techgibberish for me to understand.
but atleast it now confirmed the succesful installation of IE7 and IE8.
now the byond launcher is stuck on that black loader with byond icon. it never finishes loading anything. just stuck there.
so it's a real throwback now.

ran the same commands again and now it loaded as before...
lets see if i can join a server now - nope, dreamseeker.exe still crashing.

the only step i couldnt do was this:
"Edit your wineprefix regedit using wine's regedit:

HKEY_CURRENT_USER --> Software --> Wine --> Network --> UseDnsComputerName

Set 'UseDnsComputerName' key to 'N' "

because there's no entry "Network" in there.
In regedit IIRC you can simply create keys that don't already exist and they will magically work.
Also run DreamSeeker through the command line to see error messages before they disappear.
i added that key, but i don't know if the entry should be a boolean, int, float, string...
i was only able to add it as String... maybe that was wrong too...
sometimes the type of variable is very important, sometimes the system just does its magic...

i uploaded the logfile to my dropbox: https://www.dropbox.com/s/hpo3xlk268kcvjv/ playonlinux.log?dl=0
maybe someone else can see an obvious problem i am oblivious to. i already went through it and couldn't see anything that called "go install this package, it can't work without it oviously! even my gramma would've seen that!" :D
Check this out:

+->UseDnsComputerName
[Set to N if you need a persistent NetBIOS ComputerName that possibly differs from the Unix host name. You'll need to set ComputerName in HKLM\System\CurrentControlSet\Control\ComputerName\ComputerN ame]

And

+->ComputerName
[Current computer name.
Updated automatically from Unix host name unless UseDnsComputerName=N]

found from https://wiki.winehq.org/Useful_Registry_Keys
which states that all registry keys there are strings (REG_SZ) unless otherwise stated. So they are strings indeed. Haven't looked at the log yet, though.
I think you're missing some essentials. May have to go to PlayOnLinux forums or install abd configure Wine directly.
might also be that some of those essentials are already included in the distros the tutorial writers use.
in some months, i'll have the cash to buy a SSD and install win10 on it... although i'l keep this old HDD as emergency backup. but i'll be abl to natively run byond.
Just wanted to let you know that I installed BYOND on Arch using Wine and it gave me far superior performance to a VM (I have no dedicated GPU) and it seems to work very well. I used only the instructions provided by Linux Guild and WineHQ, with winetricks.

In fact, the only thing I deviated from is WinePrefix I made into a symlink on my HDD.
Actually, I guess I did a little bit differently. I did not perform any registry tweaks and I had to install 32-bit headers. Your mileage may vary and maybe you will need the registry tweaks.

You are on Ubuntu, so I will try to translate what I did here for you. You need 32-bit libraries. You may want to uninstall PlayOnLinux and Wine first.

Also, I get butt tons of errors but it still works. Many of them are regarding tooltips.

sudo dpkg --add-architecture i386

wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add winehq.key
sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main'

sudo apt update
sudo apt install libsdl2-2.0-0 libsdl2-2.0-0:i386 libsdl2-dev
sudo apt install libfaudio libfaudio:i386 libfaudio-dev

sudo apt update
sudo apt install --install-recommends winehq-stable


Install any missing dependencies if you receive complaints about them and repeat the last two steps.

Then you will run winecfg. It will complain about missing Mono and Gecko. You can simply install those through those dialogs here.

winecfg



Now you will want to set up a 32-bit Wine prefix and install dependencies, starting with winetricks, and finally BYOND:

cd ~/Downloads
wget https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks
chmod +x winetricks
sudo mv winetricks /usr/bin

export WINEPREFIX=~/.wine-byond
WINEARCH=win32 winecfg
WINEARCH=win32 wineboot
winetricks corefonts wsh56 wsh57 jscript mfc42 vcrun6
winetricks ie7
winetricks ie8
wine [insert byond.exe name in Downloads]
wine "C:\Program Files\BYOND\bin\byond.exe"


Ubuntu is kind of a pain in the ass with its outdated repositories so you might run into some trouble because of that. Let me know if you do run into any trouble.




Login to reply.