Applying two filters successively could sometimes cause them to fail to render.
BYOND Version:515
Operating System:Windows 10 Pro 64-bit
Web Browser:Firefox 107.0
Applies to:Dream Seeker
Status: Resolved (515.1603)

This issue has been resolved.
I want my money back

Descriptive Problem Summary:
It appears that having more then one alpha filter on a plane master can lead to both filters just failing to effect anything. if either one is removed, or points to a render_source that doesn't exist, then the other will display.

I can't get this to replicate on bare byond, so I've stripped a version of /tg/ to be faster to init, and easy to test with. I'm gonna provide my repro steps for that.

Numbered Steps to Reproduce Problem:
Join game
Hit observe
Click on debug tab in the top right
Click on one of two toggles to disable a filter (Both filters mask the lighting plane. one for emissive objects, and the other for a secondary lighting system we use called object lighting)
Watch as the other filter suddenly takes effect

Code Snippet (if applicable) to Reproduce Problem:

Expected Results:
Both filters properly masking the PM

Actual Results:
Neither filter masks the PM

Does the problem occur:
Every time? Or how often? Yes
In other games? No Idea
In other user accounts? Yes
On other computers? Yes

When does the problem NOT occur?
On older CLIENT versions of byond. The version the server is running does not appear to matter here, seems to be a clientside thing

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.)
Works up to latest 514, I haven't narrowed down 515, I can if you'd like

Get up from your desk and take in the sweet smell of spring.
I've taken a look at this and I honestly have no clue what I'm supposed to be seeing. If I toggle one of the filters on (but not both) I see the player with a light around them. What's wrong with what I'm seeing? What should I be seeing instead?

The project is still way too bloated for me to do any meaningful debugging. If I run it in Dream Seeker it's taking ginormous amounts of memory, when there really should be a way to recreate the render stack in a simpler project. All of the subsystems and such are totally unnecessary for tests like this, and it'd help you narrow down these sorts of issues if you had a way to run the render stack in a reduced environment.
Lummox JR resolved issue with message:
Applying two filters successively could sometimes cause them to fail to render.