Hello, I have tried read some posts of how to host in byond using linux terminal, but every time that I try I get the same results
steps I tried:
sudo apt-get install unzip
sudo apt-get install make
sudo apt-get update
cd byond
sudo make install

It looks everything is ok, I get the message
You can find out more about the software by doing 'man DreamDaemon'.
A host server has also been included so edit host/hostconf.txt and
boot up your world server!

Now I try
sudo DreamDaemon -version
sudo: unable to execute /usr/local/bin/DreamDaemon: No such file or directory

There's "DreamDaemon DreamDownload DreamMaker" at this directory
You're likely on a 64-bit system, you need to install multiarch libraries. On older systems it would be the "ia32-libs" library, but on newer ones I believe you need to install all of the following:

From a quick Google of what ia32-libs was replaced with, I could be wrong though, it's been a long time since I had to do it.
In response to Nadrew
omg thank you, that was what was missing, for anyone with the same problem
sudo apt-get install lib32z1 lib32ncurses5 lib32stdc++6